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While the best efforts have been made in preparing this
manuscript, no liability is assumed by the authors with
respect to the use of the information provided.

Applied Maths will provide support to research
laboratories in developing new and highly specialized
applications, as well as to diagnostic laboratories where
speed, efficiency and continuity are of primary
importance. Our software thanks its current status for a
part to the response of many customers worldwide.
Please contact us if you have any problems or questions
concerning the use of GeneMaths XT, or suggestions for
improvement, refinement or extension of the software to
your specific applications:

Applied Maths NV
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Belgium
PHONE: +32 9 2222 100
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LIMITATIONS ON USE                                                             

The GeneMaths XT software and this accompanying
guide are subject to the terms and conditions outlined in
the License Agreement. The support, entitlement to
upgrades and the right to use the software automatically
terminate if the user fails to comply with any of the
statements of the License Agreement.

No part of this guide may be reproduced by any means
without prior written permission of the authors.
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1. Import
1.1 Downloading the data

An example dataset will be used in order to explain the
workflow of GeneMaths XT. This dataset is publicly
available on the GEO website (‘Gene Expression
Omnibus’). 

1.1.1 Go to the GEO homepage: http://
www.ncbi.nlm.nih.gov/geo, click in the box next to
‘Query > GEO accession’ and type GDS742.

1.1.2 Press <Go>.

1.1.3 Select GSE1652 in the GDS Summary panel next to
Series.

1.1.4 Scroll down the next page and select SOFT
formatted family file(s).

1.1.5 On the next page select GSE1652_family.soft.gz.

1.1.6 Select <Save> and navigate to a path on your
computer.

1.1.7 Press <Save> to save the file in the selected folder.

1.2 Importing the data in GeneMaths XT

1.2.1 Start GeneMaths XT by double clicking on the icon

 on the desktop or from the task bar with Start >

Programs > Applied Maths > GeneMaths XT.

1.2.2 Click <Next> in the welcome screen to begin the
import of the data. If the welcome screen does not
appear, choose File > Import Wizard in the GeneMaths
XT Main window. The Import Wizard window pops up
(see Figure 1-2).

1.2.3 Select the fourth option, Import from other sources
and hit <Next>.

1.2.4 Select GEO’s SOFT family in the format list. A
short description of the format is shown in the right
panel (see Figure 1-3).

1.2.5 Click <Next>.

1.2.6 Browse for the stored file in the File panel. You can
leave the top two panels empty (see Figure 1-4).

Figure 1-1. Download information.

Figure 1-2. Import wizard: select data source. 

Figure 1-3. Import wizard: select format. 
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1.2.7 Click <Next>. 

1.2.8 Specify the name of the processed file e.g.
GDS742.xps.

1.2.9 The Calculation dialog box pops up. The status of
the import of the data is shown (see bottom of the box). 

1.2.10 After the processing of the data (this may take a
couple of minutes) GeneMaths XT will prompt to
specify the contents of the columns in the Define Format
dialog box (see Figure 1-5).

1.2.11 Select the second column, ‘ID_REF’ by clicking on
it. The column is highlighted in pink. Specify the kind of
data in this column by changing the settings in the
Column Information panel. Select Text in the Type box
and Spot ID in the Text box (see Figure 1-6).

1.2.12 Select the third column (‘CH1_MEAN’).
Quantitation, Target, Foreground and Value are
automatically selected as the settings for the third
column (see Figure 1-7).  

GeneMaths XT automatically assigns the correct settings to
columns 3-6 as specified in the dataset file. Only for column 2
and 7 the settings need to be changed.

1.2.13 Select the last column and fill out the correct
settings (last row in Figure 1-8).

Figure 1-4. Start wizard: Input file. 

Figure 1-5. The Define format
dialog box. 

Figure 1-6. Settings for the
second column. 
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1.2.14 After specifying the correct column information
for all data columns press <OK>.

1.2.15 The Import mapping dialog box pops up asking
you to create a mapping for your data. This mapping
tells GeneMaths XT which quantitations to use in the
session.

1.2.16 Select ID-REF and hit “>”. ID-REF is now placed
in the right box (see Figure 1-9).

1.2.17 Click <Next>.

1.2.18 Mark the two checkboxes in the Filter panel of the
next dialog box. Marking these boxes means we want to
load both channels in a different layer and that we want
to have the background for each channel in a different
layer as well (see Figure 1-10).

1.2.19 In the Quantitations panel, use all four
quantitations without an error value (see Figure 1-10),
simply because there are no errors provided in the GDS
file. Use the pull down menu to select the predefined
signals.

1.2.20 In the next step of the import, select VALUE in the
first column, select No error in the second column and
hit “>” (see Figure 1-11). VALUE is now used as an extra
quantitation.

1.2.21 Click <Next>.

GeneMaths XT will import the data in a new session.
The Main window of GeneMaths XT appears as depicted
in Figure 1-12. The session contains 5 layers (displayed
in the top left panel), 3 row identifiers and 5 column
identifiers (see Figure 1-14 and Figure 1-14).          

NOTE: Do not forget to save your session on a regular basis

by pressing .

Figure 1-7. Settings for
the third column. 

Column   Type   Quantitation    
4   (CH1_BKG_MEAN) Quantitation Target  Background Value 
5   (CH2_MEAN)  Quantitation Reference     Foreground Value 
6   (CH2_BKG_MEAN) Quantitation Reference Background Value 
7 (VALUE)  Quantitation Ratio  Foreground Value 

Figure 1-8. Settings for the different columns. 

Figure 1-9. The Import mapping dialog box: step 1. 
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Figure 1-10. Import mapping: step 2. 

Figure 1-12. The Main window of GeneMaths XT after import of the data. 

Figure 1-13. The column identifiers.

Figure 1-11. Import mapping: step 3. 

Figure 1-14. The row identifiers. 
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2. Annotation
2.1 Row annotation

The annotation is automatically with the import of the
file. The spots however, do not yet contain the GO ID as
an identifier. 

Several steps are needed in order to get the GO IDs for
the genes. We will start from the GenBank accession
numbers (GB_acc is one of the 3 row information fields,
see Figure 1-14) and convert them to Unigene, then from
Unigene to Entrez and then finally from Entrez to GO
IDs. This is to show that there is a logical connection
between all of these. 

Please note that this long procedure is only needed when
using custom arrays. For Affymetrix arrays we can use a
direct import of annotations (see One Color Tutorial and
GSEA Tutorial).

2.1.1 Select Textfields > Annotations > Genbank to
Unigene. Select Rattus norvegicus as the organism and
use GB_ACC as the GenBank ID (see Figure 2-1). Click
<OK>. 

Please be patient while GeneMaths XT is importing.
When finished, you will have an extra row identifier
named Unigene Cluster ID (see Figure 2-2).

2.1.2 Select Textfields > Annotations > Entrez Gene.
Choose Entrez Gene To Unigene and press <OK> (see
Figure 2-3). 

2.1.3 In the next window, select the Unigene Cluster ID
(left), the UniGene Cluster (right) and GeneID in the
bottom panel (see Figure 2-4). 

With these settings the Unigene Cluster IDs are linked to
the UniGene Cluster information in the external
annotation file. GeneID is added to the row information
fields (see Figure 2-5).

Figure 2-1. Conversion of GenBank accession
numbers to Unigene. 

Figure 2-2. Unigene Cluster ID. 

Figure 2-3. Get Entrez information. 

Figure 2-4. Linking the information.

Figure 2-5. Gene ID in the list of row identifiers. 
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2.1.4 Select once more Textfields > Annotations > Entrez
Gene, but this time select Entrez Gene To GO and press
<OK>.

2.1.5 Fill out the next dialog with the settings shown in
Figure 2-6 and press <OK>.

2.1.6 GO ID is added to the list of identifiers. Select GO
ID from the list. The available GO ID(s) for each row
entry is/are shown (see Figure 2-7).

2.2 Column annotation

Four column identifiers are present after import of the
data. In a next step, we are going to split the information
present in the description information field (see Figure
2-8).

2.2.1 Select Textfields > Split. Fill out the dialog box as
shown in Figure 2-9. Press <OK>.

Two column identifiers (days and tissue) are added to
the list of column identifiers (see Figure 2-10). 

2.2.2 Select the tissue identifier from the list. The
information in the Column names panel is updated (see
Figure 2-10). 

As a last step, we will rename the column identifier
description to disease state.

2.2.3 Select Textfields > Rename and fill out the dialog
box as shown in Figure 2-11. Press <OK>. 

Figure 2-6. Adding the GO ID in the final step. 

Figure 2-7. GO ID in the list of identifiers .

Figure 2-8. The description column identifier.

Figure 2-9. Split textfields.

Figure 2-10. The column identifiers.

Figure 2-11. Rename a textfield.
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3. Groupings
With the statistics we want to perform later on in mind,
we need to define groupings, each containing a set of
particular groups. The groupings will then later be the
input for the statistical tools and visualizations. 

3.1 Row groups

In the first step, we want to make row groups from the
GO IDs. 

3.1.1 Select Groups > Edit Row Groups and click on
<Create New Grouping>. 

3.1.2 In the next window, select GO ID from the Name-
pull down menu and click <OK> (see Figure 3-1).

3.1.3 GO ID is selected as the text field in the next
window (see Figure 3-2). As you can see in the gene
identifier list (see Figure 2-7), the same gene can contain
multiple GO IDs, separated by a “|” (e.g.
GO:0006955|GO:0005529|GO:0007166). Use a “|” (a

pipe) for the delimiter. This will split the multiple IDs
for a certain row entry. 

3.1.4 Specify the limitations as shown in Figure 3-2. The
filtering is useful because we do not want small groups,
this would make them useless in further analysis. Click
<OK>.

3.1.5 The groups based on the settings are shown in the
next window (see Figure 3-3).

3.1.6 Press <Exit>. 

GeneMaths XT offers the possibility to link a grouping
to a website. We will link the GO ID grouping to the
GO-website. Later on we can use this link when using
statistics reports. 

Figure 3-1. Grouping from the GO IDs. 

Figure 3-2. Creating groups based on the GO ID. 

Figure 3-3. Groups
based on GO IDs .
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3.1.7 Select Groups > Row Group Link.

3.1.8 In the next dialog box, select GO ID and ‘http://
www.godatabase.org/cgi-bin/amigo/go.cgi?action=
replace_tree&query=###’. Click <OK>.  

3.2 Column groups

In the next step, we want to make groups from the
column information fields tissue and disease state (see
section 2.2). 

3.2.1 Select Groups > Edit Column Groups and click on
<Create New Grouping>. 

3.2.2 In the next window, select tissue from the Name-
pull down menu and click <OK> (see Figure 3-5).

3.2.3 Tissue is selected as the text field in the next
window (see Figure 3-6). Uncheck ALL the limitations
and click <OK>.

3.2.4 The groups based on the settings are shown in the
next window (see Figure 3-7).

RV = right ventricle

LV= left ventricle

Figure 3-4. Create a group link.

Figure 3-5. Grouping from tissue. 

Figure 3-6. Creating groups based on the tissue. 

Figure 3-7. Groups based on the tissue. 



Chapter 3 - Groupings 13
3.2.5 Repeat steps 3.2.1 until 3.2.3 for disease state (see
3-8).

CHF = decompensated hypertrophy

CON = control

HYP = compensated hypertrophy

3.2.6 Press <Exit>.

Figure 3-8. Groups based on the disease states. 
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4. Preprocessing
4.1 The preprocessing diagram

In order to perform data analysis on this dataset, we first
need to preprocess our data.  

4.1.1 In GeneMaths XT, select Layer > Preprocessing
diagram. 

In the Preprocessing window, all layers present in the
session are displayed. On the right side of the window,
the preprocessing tools are listed. 

4.1.2 Uncheck Overwrite by default.  

4.2 Background correction

4.2.1 In the Preprocessing window, select the Target and
TargetBackgr layer. To select both layers hold the CTRL
key. 

4.2.2 Select Background correction from the list tools. 

A description of this tool is displayed below the list of
preprocessing tools. 

4.2.3 Press <Add>. Double clicking on the tool in the list
does the same. 

4.2.4 Leave the settings in the next window unaltered
and press <OK>. 

4.2.5 In the next window, store the background
corrected values in a new layer called Tar_BG_corr. 

NOTE: Make sure you have unchecked the option
Overwrite by default.

4.2.6 Press <OK>.

4.2.7 The result of the background substraction is stored
in the Tar_BG_corr layer. 

4.2.8 Click on the arrow in the Background correction
box. Two parameters are displayed. 

4.2.9 To change the parameters, double click in the pink
box. 

4.2.10 Check Exponential + normal model and press
<OK>. 

4.2.11 Repeat step 4.2.1 - 4.2.10 for the Reference and
ReferenceBackgr layer. Store the result in a new layer
called Ref_BG_corr and make sure the Exponential +

Figure 4-1. Preprocessing window. 

Figure 4-2. Define a new destination layer.

Figure 4-3. Background correction settings.
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normal model is selected from the list of available
algorithms.

The Preprocessing window should now look like Figure
4-4.

4.3 Log transformation

In the next step we are going to make new layers that are
the logarithm of the newly created background
substracted layers (Tar_BG_corr and Ref_BG_corr). The
log transformed layers will have a normal distribution.
This is a prerequisite to perform several statistical tests
on your data.

NOTE: Make sure you have unchecked the option
Overwrite by default in the Preprocessing window.

4.3.1 Select the layer Tar_BG_corr in the Preprocessing
window. 

4.3.2 Select Log Transform from the list of preprocessing
tools and press <Add>. Double clicking on the name
does the same.

4.3.3 Store the result of the log transformation in a new
layer called LogTar. 

4.3.4 Press <OK>.

4.3.5 Repeat the previous step for the Ref_BG_corr
layer. Store the values in a layer called LogRef (see
Figure 4-5).

4.3.6 Press <OK>.

A Calculation dialog box pops. After calculating the
preprocessing steps defined in the Preprocessing
window, the new layers are added to the list of layers in
the Layers window (see Figure 4-6). 

Figure 4-4. The Preprocessing window: Background correction. 

Figure 4-5. The Preprocessing window: Log Transformation. 
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4.4 Normalization 

First we are going to take a look at the data as it is now. 

4.4.1 Select Profiles > Plot Wizard. Select Columns as
the orientation. Because we want different layers to plot
against each other (LogTar vs. LogRef) select One
column, different layers and click <Next>.

4.4.2 In the next window select Entries. Select all entries
and click <Next> to move to the next step (see Figure 4-
8). 

4.4.3 In the third window, select the two log transformed
layers LogRef and LogTar. Click “>” and click <Next>
(see Figure 4-9).

4.4.4 In the final window, select MA-plot in the Plot type
panel and Curve color in the Color panel (see Figure 4-
10). Click <Finish>. (M=log2(Red Intensity/Green
Intensity) and A= v(Red Intensity x Green Intensity)).

Figure 4-6. The Layers window with the new
layers. 

Figure 4-7. Plot Wizard: step 1. 

Figure 4-8. Plot Wizard: step 2. 

Figure 4-9. Plot Wizard: step 3. 

Figure 4-10. Plot Wizard: final step. 
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The plot appears in GeneMaths XT (see Figure 4-11). We
need to set the X and Y axes correctly for the plot.

4.4.5 Select the profile of the LogRef layer in the Profiles
panel (see left panel in Figure 4-11). Click right and
choose Set as y-axis.

4.4.6 Select the profile of the LogTar layer and choose
Set as x-axis.

4.4.7 Select Profiles > Selected Profile > XY to RI.

4.4.8 Select Profiles > Selected Profile > Lowess Plot.
Press <OK>.

The plot should now look like the one in Figure 4-12.

The MA-plot (see Figure 4-12) shows that at a certain
average level of intensities, the ratio M approximates a
certain constant level. However, when A (= intensity) is
below a certain threshold the ratio deviates from this
constant level. This means that the detection levels for
underexpression differ between the two channels. Long
story short, the extreme deviation of the plot is caused
by a difference in sensitivity between the two channels.
A solution for this problem is to use an ‘intensity
dependent normalization’. We will use the Lowess
normalization to compensate for these intensity
dependent effects. 

4.4.9 Select Layer > Preprocessing diagram. 

4.4.10 In the Preprocessing window, select the LogTar
and LogRef layers. To select both layers hold the CTRL
key. 

4.4.11 Select Lowess from the list of preprocessing tools
and press <Add>. Double clicking on the name does the
same.

The result of the Lowess normalization is stored in the
LogTar and LogRef layers (see Figure 4-13). 

4.4.12 Press <OK>.

Figure 4-11. MA-plot. 

Figure 4-12. MA-plot with the corrected axes. 
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4.4.13 Select the first profile in the Profiles panel. Click
right and choose Edit Profile (see Figure 4-14). Click
<OK>.

4.4.14 Repeat the previous step for the other two profiles
in the Profile panel. The plot should now look like Figure
4-15. 

There is a clear compensation for the intensity
dependent effect. Lowess thus allows for both
normalization and linearization of the data.

4.5 Ratio

We are going to substract LogTar and LogRef from each
other in order to calculate the ratio of the layers. 

4.5.1 Select Layer > Preprocessing diagram. 

4.5.2 In the Preprocessing window, select the LogTar and
LogRef layers. To select both layers hold the CTRL key. 

4.5.3 Select Ratio from the list of preprocessing tools and
press <Add>. Double clicking on the name does the
same.

4.5.4 Store the values in a new layer called Ratio. Press
<OK>.

4.5.5 Press <OK>.

The Ratio layer is created and is added to the list of
layers in the Layers window.

The new layer Ratio is a good starting point for
statistical analysis. The histogram in the Main window
shows a Gaussian distribution, centered around zero.

Figure 4-13. The Preprocessing window: Lowess. 

Figure 4-14. The Profiles panel.

Figure 4-15. The MA-plot after Lowess
normalization. 

Figure 4-16. The Preprocessing window: ratio.
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5. Statistics & Analysis
In the last step we will perform an ANOVA test on the
control (CON) and decompensated hypertrophy (CHF)
arrays of the right ventricle (RV). 

In a first step we are going to make a subset, containing
all arrays of the right ventricle.

5.0.1 Click on the down arrow next to the column

groupings button  and select tissue from the
drop-down menu. The tissue is now set as grouping. 

5.0.2 Select tissue from the list of column identifiers. 

5.0.3 In the Group window, select the tissue grouping
from the list of defined groupings (see Figure 5-2).

All groups belonging to the tissue grouping are listed in
the Group window (see Figure 5-2).

5.0.4 CTRL click on the square next to RV (see Figure 5-
2)..  

All arrays belonging to the RV (=right ventricle) group
are selected in the Column panel (see Figure 5-3).

5.0.5 Select Subset > Selection to Subset and name the
subset Right ventricle (see Figure 5-4). Press <OK>.  

5.0.6 In the Main window, the Right ventricle subset is
stored as a subset of the Complete set. 

5.0.7 Clear the selection by pressing F4. 

Next we are going to select the arrays belonging to the
decompensated hypertrophy and control disease state. 

5.0.8 First make sure that the Right ventricle subset is
selected in the Main window. 

5.0.9 Click on the down arrow next to the array

groupings button  and select disease state
from the drop down menu. The disease state is now set
as grouping. 

Figure 5-1. List of column identifiers.

Figure 5-2. The Group window. 

Figure 5-3. Selected arrays.

Figure 5-4. Creating a subset of the complete set.

Figure 5-5. The Subsets window.
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5.0.10 Select disease state from the list of column
identifiers (see Figure 5-1). 

5.0.11 In the Group window, select the disease state
grouping from the list of defined groupings (see Figure
5-6).

All groups belonging to the disease state grouping are
listed in the Group window (see Figure 5-6).

5.0.12 CTRL click on the square next to HYP and CHF
(see Figure 5-6)..  

All arrays belonging to the CON (= control) and CHF
(decompensated hypertrophy) groups are selected in the
Column panel (see Figure 5-7).

5.0.13 Select Subset > Selection to Subset, name the
subset Decompensated vs. Control and enable Child of
the current subset. Press <OK>.  

The Subsets window should now look like this: 

5.0.14 Select Profiles > Statistics Wizard. Leave the
orientation on Row set Decompensated vs. Control as
subset and press <Next>. 

5.0.15 Select ANOVA test (under ‘Independent test
(multiple groups)’) from the list and click <Next> (see
Figure 5-10).

5.0.16 In the next window, make sure that Ratio is
selected and the disease state in the Groups panel. Select
p-value as output and click <Next> (see Figure 5-11).

Figure 5-6. The Group window. 

Figure 5-7. Selected arrays.

Figure 5-8. Creating a subset. 

Figure 5-9. Statistics Wizard, step 1. 

Figure 5-10. Statistics Wizard, step 2. 
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5.0.17 In the last window, choose the Benjamini &
Hochberg procedure to correct for multiple testing and
press <Finish> (see Figure 5-12).

5.0.18 Click on the newly created profile in the Profiles
tab. Right-click on the profile name and select Sort From
Profile (see Figure 5-13).

5.0.19 Right click in the Profile panel (see Figure 5-14)
and select Show as Numbers. 

In the Profile panel, the p-values for the row entries are
shown. These p-values give an indication if the entries
are significantly differentially expressed between the
two groups or not. The lower the p-values the more
differentially expressed. 

5.0.20 Right-click in the Profile panel (see Figure 5-14)
and select Query From Profile.

5.0.21 Set the threshold of the p-values to ‘< 0.05’ and
press <OK>. 

All entries having a p-value of less than 0.05 are selected
(see Figure 5-15) 

Figure 5-11. Statistics Wizard, step 3. 

Figure 5-12. Statistics Wizard, step 4. 

Figure 5-13. Sort From Profile. 

Figure 5-14. Show as Numbers. 

Figure 5-15. Selected row entries. 
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