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1. Import

1.1 Downloading the data

An example dataset will be used in order to explain the
workflow of GeneMaths XT. This dataset is publicly
available on the GEO website (‘Gene Expression
Omnibus”).

1.11Go to the GEO  homepage: http://
www.ncbi.nlm.nih.gov/geo, click in the box next to
‘Query > GEO accession” and type GDS724.

1.1.2 Press <Go>.

1.1.3 Select GSE1563 in the GDS Summary panel next to
Series.

1.1.4 Scroll down the next page and select SOFT
formatted family file(s).

Download family Format
SOFT formatted family file(s) SOFT
MINIML formatted family file(s) MINIML
Series Matrix File(s) TXT

Figure 1-1. Download information.

1.1.5 On the next page select GSE1563_family.soft.gz.

1.1.6 Select <Save> and navigate to the path on your
computer.

1.1.7 Press <Sawe> to save the file in the selected folder.

1.2 Importing the data in GeneMaths XT

1.2.1 Start GeneMaths XT by double clicking on the icon

on the desktop or from the task bar with Start >
Programs > Applied Maths > GeneMaths XT.

1.2.2 Click <Next> in the welcome screen to begin the
import of the data. If the welcome screen does not
appear, choose File > Import Wizard in the GeneMaths
XT Main window. The Import Wizard window pops up
(see Figure 1-2).

1.2.3 Select the fourth option, Import from other sources
and hit <Next>.

Imnport Wizard @

Source =
The Import Wizard guides you through the process of importing data in e
GeneMaths ¥T and starting a session. g - g

;J) _ Load an existing GeneMaths XT Session

=|| > Import a set of files each containing one array
O =" Typically used for importing files straight from the image analysis software

Import one text file containing set of arrays
"I * O Typically used if preprocessing was carried out outside GeneMaths XT

Import from other sources
= Examples are databases, internet repositories, XML files, etc.

L]
v
©

J) Import from an existing experimental design file
= E.g. add arrays to an earlier defined experimental design

Cancel

Figure 1-2. Import wizard: select data source.

1.2.4 Select GEO’s SOFT family in the format list. A
short description of the format is shown in the right
panel (see Figure 1-3).

Import Wizard (5]
s e
Format il
Select the format your data is in from the list. @t Z'
Format Description

EBI MIAME GEO is a public internet -~
GEQ's SOFT series database containing many
datasess.

The SOFT family file can be
downloaded under ‘Download | -
Family' under 'SOFT T
formatted family file(s)' from

the Full Dataset Record page

on the GEO website.

Imports the raw data from a
GEO series into GeneMaths

¥T, it may contain multiple il

I Change Existing Format = I

I My Format is not in the List ==

n
&

Cancel

Figure 1-3. Import wizard: select format.

1.2.5 Click <Next>.

1.2.6 Browse for the stored file in the File panel. You can
leave the top two panels empty (see Figure 1-4).
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Import Wizard

MName

Spedes

homo sapiens

Experiment parameters
Specify the experiment parameters

Format : GEQ's SOFT family

File
... \GSE1563_famiy_soft.gz| Browse...
|:| Time Course Experiment Annotate Genes ==
[ Load Experiment ] [ Save Experiment ] [ Save Experiment As ]
[ < Back. ][ Next = ] [ Finish ] [ Cancel ]

Figure 1-4. Start Wizard: input file.

1.2.7 Click <Next>.

1.2.9 The Calculation dialog box pops up. The status of
the import of the data is shown (see bottom of the box).

1.2.10 After the processing of the data (this may take a
couple of minutes) GeneMaths XT will prompt to
specify the contents of the columns in the Define Format
dialog box (see Figure 1-5).

1.2.11 Select the second column ID_REF by clicking on
it. The column is highlighted in pink. Specify the kind of
data by changing the settings in the Column information
panel. Select Text in the Type box and Gene ID in the
Text box (see Figure 1-6).

1.212 Select the third column VALUE. Select
Quantitation in the Type box and Target, Foreground
and Value in the Quantitation box (see Figure 1-7).

1.2.13 Select the fourth column. Select Quantitation in
the Type box and Target, Foreground and Quality
control in the Quantitation box (see Figure 1-8).

1.2.14 Press the <Next & Copy> button. The fifth column
now contains the same settings as the fourth column.

1.2.8 Specify the name of the processed file e.g.
GDS724.xps.
Define Format @
Data Position Column Information
[@]Read column titles Click on a column. Type
-
First line of data 1 =
Description
Advanced settings > >
[ Reget Al ] [ Go Mext = ] [Next&cupy > ]
Conterts ID_REF VALUE ABS_CALL DETECTION P-V. -
Spot 1D value Text value =
1 (Titles) ID_REF VALUE ABS_CALL DETECTIOM P-V... B
2 (Data) AFFX-Murll2_at 2115 A 0.50000
3 (Data) AFFX-MurIL10_at 190.2 A 0.23905
4 (Data) AFFX-Murll4_at 96.5 A 0.68628
5 (Datz) AFFX-MurFAS_at 80.8 A 0.55935
6 (Data) AFFX-BioB-5_at 847.3 P 0.00202
7 (Data) AFFX-BioB-M_at 978.7 P 0.00004
8 (Data) AFFX-BioB-3_at 1045.4 P 0.00010
9 (Data) AFFX-BioC-5_at 2050.4 P 0.00010
10 (Data) AFFX-BioC-3_at 20325 P 0.00004
11 (Data) AFFX-BioDn-5_at 1750.5 P 0.00006 -
Figure 1-5. The Define
seed | [_ox | (= ||| Format dialog box.
Define Format @
Data Position Column Information
Read column titles ID_REF Type
- Text - SpotID -
First ine of data 1 =
Description
[ Reset All ] [ Go Mext > ] [ Mext & Copy = ]
Contents ID_REF VALUE ABS_CALL DETECTION P-V. -
Spot ID value Text value =
1 (Titles) ID_REF WALUE ABS_CALL DETECTION P-V... [
2 (Data) AFFX-MurlL2_at 2115 A 0.50000
3 (Data) AFFX-MurIL10_at 180.2 A 0.23%08
4 (Data) AFFX-MurlL4_at 96.5 A 0.68628
5 (Data) AFFX-MurFAS_at 80.8 A 0.55935
6 (Data) AFFX-BioB-5_at 847.3 P 0.00202
7 (Data) AFFX-BioB-M_at 978.7 P 0.00004
8 (Data) AFFX-BioB-3_at 1045.4 P 0.00010
9 (Data) AFFX-BioC-5_at 2050.4 P 0.00010
10 (Data) AFFX-BioC-3_at 2032.5 P 0.00004
11 (Data) AFFX-BioDn-5_at 1750.5 P 0.00006 - . .
Figure 1-6. Settings for the
g | [ o< | [ cnd || second column.
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Define Format @
Data Position Column Information
Read column titles VALUE Type Quantitation
— Quantitation Channel: Target -
Firstline of data 1 ~
Description Background :  Foreground -
Advanced settings >> Character :  Value -
[ Reset All ] [ Go Mext = ] [Next&capy > ]
Cortents ID_REF VALUE ABS_CALL DETECTION P-V... -
Spot 1D target target QC target QC
1 (Titles) ID_REF VALUE ABS_CALL DETECTION P-V...
2 (Data) AFFX-MurIL2_at 211.5 A 0.50000
3 (Data) AFFX-MurIL10_at 130.2 A 0.23506
4 (Data) AFFX-MurIl4_at 96.5 A 0.68528
5 (Data) AFFX-MurFAS_at 80.8 A 0.55935
& (Data) AFFX-BioB-5_at 847.3 P 0.00202
7 (Data) AFFX-BioB-M_at 978.7 P 0.00004
3 (Data) AFFX-BioB-3_at 1045.4 P 0.00010
3 (Data) AFFX-BioC-5_at 2050.4 P 0.00010
10 (Data) AFFX-BioC-3_at 2032.5 P 0.00004
11 (Data) AFFX-BioDn-5_at 1750.5 P 0.00006 -
< Back ] [ OK. J [ Cancel ]
Define Format @
Data Position Column Information
Read column titles ABS_CALL Type QI
< Quantitation Channel: Target -
First line of data 1 ~
Description Background :  Foreground -
Character :  Quality control -
[ Reset All ] [ Go Mext = ] [Next&Copy = ]
Contents ID_REF VALUE ABS_CALL DETECTION P-V..
Spot ID target target QC target QC
1 (Titles) ID_REF VALUE ABS_CALL DETECTION P-V...
2 (Data) AFFX-MurlL2_at 211.5 A 0.50000
3 (Data) AFFX-MurIL10_at 190.2 A 0.23908
4 (Data) AFFX-MurlL4_at 96.5 A 0.68628
5 (Data) AFFX-MurFAS_at 80.8 A 0.55935
6 (Data) AFFX-BioB-5_at 847.3 P 0.00202
7 (Data) AFFX-BioB-M_at 978.7 P 0.00004
8 (Data) AFFX-BioB-3_at 1045.4 P 0.00010
9 (Data) AFFX-BioC-5_at 2050.4 P 0.00010
10 (Data) AFFX-BioC-3_at 2032.5 P 0.00004
11 (Data) AFFX-BioDn-5_at 1750.5 P 0.00008 -
< Back ] [ Ok ] [ Cancel ]
Define Format ﬁ
Data Position Column Information
) T titat
Read column titles PEEDNT L £ Quantitation
- Quantitation - Channel: Target -
First line of data 1 =
Description Background :  Foreground -
Character :  Quality control -
[ Reset All ] [ Go Next > ] [Next&Copy > ]
Contents ID_REF VALUE ABS_CALL DETECTION P-V...
Spat 1D tanget target QC target QC
1 (Titles) ID_REF VALUE ABS_CALL DETECTION P-V..,
2 (Data) AFFX-MurIL2_at 211.5 A 0.50000
3 (Data) AFFX-MurlL10_at 190.2 A 0.23906
4 (Data) AFFX-MurIl4_at 96.5 A 0.68628
5 (Data) AFFX-MurFAS_at 80.8 A 0.55935
&6 (Data) AFFX-BioB-5_at 847.3 P 0.00202
7 (Data) AFF¥-BioB-M_at 978.7 P 0.00004
8 (Data) AFFX-BioB-3_at 1045.4 P 0.00010
9 (Data) AFFX-BioC-5_at 2050.4 P 0.00010
10 (Data) AFFX-BioC-3_at 2032.5 P 0.00004
11 (Data) AFFX-BioDn-5_at 1750.5 P 0.00008 -
< Back ] [ OK J [ Cancel ]

Figure 1-7. Settings for
the third column.

Figure 1-8. Settings for
the fourth column.

Figure 1-9. Settings for
the last column.
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1.2.15 After having specified the correct column
information for all 4 data columns press <OK>.

1.2.16 The Import mapping dialog box pops up asking
you to create a mapping for your data. This mapping
tells GeneMaths XT which quantitations to use in the
session.

1.2.17 Select ID-REF and hit “>”. ID-REF is now placed
in the right box (see Figure 1-10).

Import Mapping @

Textfields
Here you can select textfields to be imported into the session.

ID_REF

A

M

..€ ..) .A ..,-’\ .\‘r ..V

Rename

Cancel

Figure 1-10. Import mapping dialog box, step 1.

[ < Back ][ Next = ] Finish

1.2.18 Click <Next>.

1.2.19 Uncheck the two checkboxes in the Filter panel of
the next dialog box. In the Quantitations panel, select
‘"VALUE’ in the Target box (see Figure 1-11) and press
<Next>. Entering these settings only loads the “"VALUE'-
column as a target signal.

Import Mapping ﬁ

Source
Each array contains some principal quantitations. These can be
linked to columns from the format here.

Filter

& Load both target and reference channels in a separate layer
(e.g. Cy3 and Cy5)

|| Load the background in a separate layer for each channel

Quantitations

Signal Error
Target VALUE hd _
Target Backgr SEREreRaNaE
Reference Donireadhae
Reference Backgr O e A

Figure 1-11. Import mapping, step 2.

1.2.20 In the next step of the import, select DETECTION
P-VALUE in the first column, select No error in the
second column and hit “>” (see Figure 1-12).
‘DETECTION P-VALUE’ is now used as an extra
quantitation.

Import Mapping ﬁ

Additional Quantitations
Here you can optionally select other quantitations to importas a
layer in the session.

Here you can optionally select other quantitations to import as layers in the
SESSI0n.

Signal Error Layer

ABS_CALL Mo error DETECTION P-VALUE
DETECTION P-VALLE

] [T | »

Rename

Figure 1-12. Import mapping, step 3.

1.2.21 Click <Next>.

1.2.22 In the final step of the Import wizard you can
select which quality control criteria you want to use as a
present/absent indication. In this example we could use
the Affymetrix PMA-calls, but because we want to keep
our value layer intact and have more flexibility during
the analysis we will leave the settings unchanged.

1.2.23 Select <Finish>.

GeneMaths XT will import the data in a new session.
The Main window of GeneMaths XT appears as depicted
in Figure 1-13. The session contains two layers: “Target’
(imported from column ‘“VALUE’) and ‘DETECTION P-
VALUE’ (imported from column ‘DETECTION P-
VALUE'). The layers are displayed in the top left panel.

NOTE: Do not forget to save your session on a regular basis

by pressing el .
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GeneMaths XT - [chapterl.GMS] - [Complete set: DETECTION P-VALUE]

===

{5 File Edit View Selection Textfields Subset Layer Groups Dendrogram Analysis Classification Profiles Seript  Window mmm
ﬁ;gé,|.|9.g. g%@*%&%“ﬂ ....mullgm*‘mﬁﬁzggihmﬁ|.ﬁ;’m
€ ® R EE Bl | By Em] 38 | R Sty
Layers b4 | Selection | Dendrogram | Ord [+ | & :| Histogram | Data I Dendrogram | Pmﬁ15|
A Target Selection Rows: 0 selected '—.l
¥ DETECTION P-VALUE - 4 =
0 o -
- E n:
Selection Columns: 0 selected SEEEE22-2 23 0 0.2 0.4 0 08
o 0 00 0O 00 00 00 00 aC
i SEESE88888% Range [0.00,0.00]: 15.24%.
Ho B Percentage absent: 0.00 %.
ﬁ Complete set (Spots x Arrays) e DOOVOOO0C
AFFX-MurlL2_at o~
AFFX-MurlL10_at [
& AFFX-MurlL4_at
AFFX-MurFAS_at
= AFFX-BioB-5_at
N ] AFFX-BioB-M_at
- AFFX-BioB-3_at
G 005
AFPICBIOC-5_at
- AFFX-BioC-3_at
n AFFX-BioDn-5_at
AFFX-BioDn-3_at
AFFX-Crex-5_at
AFFX-Crex-3_at
AFFX-BioB-5_st
AFF¥-BioB-M_st
4 L] ' AFFX-BioB-3_st
AFFX-BioC-5_st
Information : DETECTION P-VALUE AFFX-BioC-3_st
: B AFFX-BioDn-5_st
(Bl script | ¥ Depe... | B Affects AFFX-BioDn-3_st
Comment: Imported from column o~ AFFX-Crex-5_st
DETECTION P2VALUE |; . AFFX-Crex-3_st
Imports a session as prescribed in the = e ;:Eg—r;‘ir:;ilu;at o
experimental design file "C:\Documents and ™ 4 D } Expression Values A| - - ID_REF(Spots) «

Current subset: Complete set: 12625 x 62

Figure 1-13. The Main window of GeneMaths XT after import of the data.
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2. Annotation
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2.1 Spot information

2.2 Spot annotation

The annotation is automatically done with the import of
the file. The spots however, do not yet contain the GO
ID as an identifier. Because this experiment is done on
an Affymetrix platform, we can directly use an
annotation file based on this specific platform.

The first thing to do is to find out what kind of array
GPL91 is and then use the corresponding *.gaf file.

211Go to the GEO  homepage: http://
www.ncbi.nlm.nih.gov/geo, click in the box next to
‘Query > GEO accession’ and type ‘GDS724’.

2.1.2 Press <Go>.

Detailed information on the dataset is shown in the GDS
Summary panel (Figure 2-1).

2.1.3 Click on the information in the Platform box. The
next page on the website gives full detail about the used
platform (see Figure 2-2). For this dataset we need the
file *Affymetrix_HG_U95Av2.gaf’.

2.2.1 Select Textfields > Annotations > Affymetrix in the
Main window of GeneMaths XT and select HG_U95Av2
from the list. Leave ‘GeneMaths GAF file’ enabled and
make sure that GeneMaths XT will check for updates on
the website (see Figure 2-3).

2.2.2 Press <OK>.

The processing may take a while depending on the
speed of your internet connection.

2.2.3 If you are using the Affymetrix annotations for the
first time you will need to subscribe yourself on the
Affymetrix website (for free). Enter your credentials and
press <OK>.

2.2.4 In the next window, use Probe set ID as a link for
ID_REF and select GO ID as information field to add to
the session.

Accession: GDS724 v View Expression (GEQ profiles)

Title: Kidney transplant rejection expression profiling

DataSet type: gene expression array-based (RNA /in situ oligonuclectide)

Summary: Analysis of kidney transplant rejection by expression profiling of kidney biopsies and peripheral blood

rejection, and well-functioning transplants.

lymphocytes from patients. Results identify expression profiles unigue to rejection, dysfunction without

Platform:

|GPLIL: affymetrix GeneChip Human Genome U35 Set HG-U95A |

Sample organism: |Homo sapiens Platform organism:

Hama sapiens

Feature count: 12651 Value type: count
Series: GSE1563 PubMed 10: 15307835
Series published: |07/14/2004 Last GO'S update: 09/21/2004
Figure 2-1. Array information on the GEO website.
Scope: | self v| Faormat: | HTML | Amount: | Quick ¥ | GEO accession: =l

Platform GPL91

Query datasets for GPLI1

Status Public on Mar 11, 2002

Title |Affymetri>< GeneChip Human Genome W95 Yersion [1 or 2] Set HG-U95A |
Technology type in situ oligonucleotide

Distribution commercial

Qrganismis) Homo sapiens

Manufacturer Affymetrix

Manufacture protocol see manufacturer's web site

Figure 2-2. Detailed array information.
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g = 2.3 Array annotation
fport nformaton for araytype Next we want to add extra information to the arrays of
ERSC'JSSPEILA_Z y our session. A file called ‘experimental.txt’ contains
EESH ;5‘,2 m additional array information for this dataset and can be

GENOMEWIDESNF _5
GENOMEWIDESNF _&
HC_G110

HG-FOCUS
HG-U133A
HG-J133A_2
HG-J1338

HG-U133_PLUS 2
Hr= 11954
< [ | b

Import Type

@ GeneMaths GAF file

() Affymetrix NetAffx Annotation f
Check for updates on website

K

Figure 2-3. Select Affymetrix Arraytype.

2.2.5 Click on the bottom right tab in the Main window
of GeneMaths XT (see Figure 2-4). GO ID is added to the
list of row identifiers.

2.2.6 Select GO ID from the list. The available GO IDs
are shown next to the spots (see Figure 2-4).

GO00075 ID_REF(Spots)
GO00068 GB_LIST(Spots)
GO00016 . N
GO00064 Species Scientific Name(5pots)
Annctation Date(Spots)
000089 SPOT_ID(Spots)
Sequence Source(Spots)
GO00063 Representative Public ID(Spots)
GO00063 Gene Title{Spots)
GO00069
Gene Symbol(Spots)
GO000BS Entrez Gene(Spots)
6000302 RefSeq Transcript ID(Spots)
Gene Ontology Biological Process(Spots)
Gene Ontology Cellular Component(Spots)
GO000G63 o ) . ’
GO00063 Gene Ontology Melecular Function(Spots)
GO00063) ® GO ID(Spots) S

found on our website.

2.3.1 Select “‘Download” in the menu bar of our home
page (www.applied-maths.com) and select ‘Manuals &
tutorials’. Select ‘GeneMaths XT Tutorials’. In the new
window, click with your right mouse button on ‘Array
Annotations” next to ‘One color design tutorial” and
select ‘Save Target As.... Save the file on your
computer.

2.3.2 Select Textfields > Import.

2.3.3 In the Import Text Fields dialog box select the aspect
Arrays and navigate to the the experimental.txt file.

2.3.4 Use the ID information in the session and the ID
column in the text file to link the information. Select all
information fields except for ID (see Figure 2-5). To
select all fields, select the first field, hold the SHIFT
button and select the last field.

2.3.5 Press <OK>.

2.3.6 Click on the column identifiers tab (see Figure 2-6).
The information fields are added to the list of column
identifiers (red rectangle).

} Expression Values & | « |_|

Figure 2-4. GO ID in the list of row identifiers.

b | GO ID(Spats)
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[ Import Text Fields

Aspect

Select an aspect: Arrays =

File

WAexperimental bt

Link

In order to connect the entries from the file to the entries in the
session you should select a column from the file and a field from
the session which contain exactly the same entries,

Browse...

Content

Please select one or more column to
import in the session as text fields,

Select a field from the session: ’ID

Select a column from the file: ’ID

Figure 2-5. Adding information fields to the list of identifiers.

#  ID(Arrays)
geo_accession(Arrays)

source_name_chl(Arrays)

ID(Amays) «

description(Arrays)
supplementary_file{Arrays)

tissue(Arrays)

individual(Arrays) Ik
Age(Arrays)

Clinical status(Arrays)

Sex(Arrays)
Immunesupression(Arrays)

Histopathology(Arrays)

Lo B on TS o R I
L e
eTEEE28 Donor type(Arrays)
Lo o B o T o I B ot}
======
T Scr (mg/dL) (Arrays)
D000 00

Days post transplant(Arrays)

Patient_ID{Arrays)

Figure 2-6. The new information fields in the list of
column identifiers.
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With the statistics we want to perform later on in mind,
we need to define groupings, each containing a set of
particular groups. The groupings will then later be the
input for the statistical tools and visualizations.

3.1 Row groups

In the first step, we want to make row groups based on
the information present in the row identifier GO ID (see
Figure 2-5).

3.1.1 Select Groups > Edit Row Groups and click on
<Create New Grouping>.

3.1.2 In the next window, select GO ID from the Name
pull down menu and click <OK> (see Figure 3-1).

New Grouping @
MName
GO 10| -
Comment
-
[ oK ] I Cancel ‘

Figure 3-1. Grouping from the GO IDs.

3.13GO ID is selected as the text field in the next
window (see Figure 3-2). As you can see in the spot
identifier list (see Figure 2-6), the same row can contain
multiple GO IDs, separated by a “|” (eg.

GO:0006955 | GO:0005529 | GO:0007166). Use a | (a pipe)
as delimiter. This will split the multiple IDs for a certain
row entry.

Generate Groups by Field (3]
Source
Text field : IGO D 'I

Separator for sub-entries (one character) |

Specifying a separator will automatically switch on overlapping
groups, thereby disabeling some statistical tests.

Limit
Maximum number of groups: 100| :
Minimum number of entries: 10 s
Maximum number of entries: 500 s
[ oK ] I Cancel J

Figure 3-2. Creating groups based on the GO ID.
3.1.4 Change the settings in the Limit panel as specified
in Figure 3-2 and click <OK>.

3.1.5 The groups based on the settings are shown in the
next window (Figure 3-3).

3.1.6 Press <Exit>.

In the Row mnames panel, the colors of the GO ID
grouping are shown next to the row entry names (see
Figure 3-4).

E' Group

Current Grouping

GO ID - Create Mew Grouping... ] I Delete Grouping... I
Existing groups: Enable overlapping groups

Group Members  Query - %J
B * GOD016568 135  Selects the items in the texttable Spots_fields whose entries in fiel ————
H © GO0D20145 131 Selects the items in the texdtable Spots_fields whose entries in fiel &J
. B GO00D4721 140  Selects the items in the testtable Spots_fields whose entries in fiel —
| O GO0D04842 113 Selects the items in the texttable Spots_fields whose entries in fiel \M
I * GOO0D30896 148  Selects the items in the texttable Spots_fields whose entries in fiel B
B * GOO0005085 108  Selects the tems in the texttable Spots_fields whose entries in fiel Edit group query
] @ GOO005768 136  Selects the items in the texttable Spots_fields whose entries in fiel _
B = GO0016757 148  Selects the tems in the texttable Spots_fislds whose entries in fiel Appearance...

| & GOOD056%4 145  Selects the items in the tesdtable Spots fields whose entries in fiel ™ .
‘ i » | Createfromfield... |

Figure 3-3. Groups

[ Ba | based on GO IDs.
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= GOD0D6378/GO000B397|C
u GO0006378|GO0006397|C New Grouping (3]
m m= GODDDB355/GOD00E412|C
Name
r GODDOGI6S(/GO0005515 tissue| -
m mam GOD006412/GOD00G412|C
m m= GODD0E412/GOD00EA12|C Comment
= m= GODDDE412/GOD0DE412(C ]
L GODODE508|GOD007338|C i
GODDOG9ES|/GO0005515
= = GO0006412/GO0005622(¢ [ ok | [ cancel |
Figure 3-4. Colors based on the row groups.
Figure 3-6. Grouping from tissue.
GeneMaths XT offers the possibility to link a grouping
to a website. In this example we will link the GO ID
grouping to the GO-website. Later on we can use this Generate Groups by Field ==
link when using statistics reports. s
ource
Text field : ltigsue vI

3.1.7 Select Groups > Row Group Link.

3.1.8 In the next dialog box, select GO ID and http://
www.godatabase.org/cgi-bin/amigo/go.cgi?action=
replace_tree&query=### from the drop down lists.
Click <OK> (see Figure 3-5).

Grouping website @
Grouping
G0 ID -
Grouping

Give a website which contains information about the groups. Fill in
###% where the name of the group is supposed to be.

http: /jwww.godatabase,org/cgi-bin/amigo fgo. coitaction=replar

K

Cancel

Figure 3-5. Linking a grouping to a website.

3.2 Column groups

In the next step, we want to make groups based on the
column information fields tissue and individual.

3.2.1 Select Groups > Edit Column Groups and click on
<Create New Grouping>.

3.2.2 In the next window, select tissue from the Name-
pull down menu and click <OK> (see Figure 3-6).

3.2.3 Tissue is selected as the text field in the next
window (see Figure 3-7). Uncheck ALL the limitations
and click <OK>.

3.2.4 The groups based on these settings are shown in
the next window (see Figure 3-8).

3.2.5 Repeat steps 3.2.1 until 3.2.3 for individual (see
Figure 3-9).

Separator for sub-entries (one character)

Spedifying a separator will automatically switch on overlapping
groups, thereby disabeling some statistical tests.

Limnit

[ Maximum number of groups: 20

[] Minimurm number of entries:

[ Maximum number of entries: 500

[ OK ] I Cancel ‘

Figure 3-7. Creating groups based on the tissue.

3.2.6 The individual grouping consists ot four groups
(see Figure 3-9):

* Acute rejection

*Renal dysfunction w/o rejection
*Normal donor

* Well functioning transplant

3.2.7 Press <Exit>.

3.3 Group window

The drop down menu in the Group window lists all
groupings defined in the database. When a grouping is
selected from the drop down menu, the groups defined
for that grouping are listed in the panel below.

3.3.1 Select for example the individual grouping from
the drop down list.

All groups defined for this grouping are listed below the
drop down list (see Figure 3-10).

Entries belonging to a group can be selected from within
the Group window.
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Figure 3-8. Groups based on the tissue.

Group ==
Curmrent Grouping
lissue - Create New Grouping... ] [ Delete Grouping... ]

Existing groups: [~] Enable overapping groups
Group Members  Gueny
. *  Lidney 31 Selects the items in the texttable Arays_fields whose entries in field §
B © peipheml . 31 Selects the items in the texttable Amays_fislds whose entries in field 6
4 [ + Create from field...

Group
Current Grouping
individuall - Create New Grouping... ] [ Delete Grouping... ]
Existing groups: [ Enable overdapping groups
Group Members  Query
. ®  acute rejection 13 Selects the items in the texttable Amays_fields whose entries ir
B O renal dysfunction w/o reje... 13 Selects the items in the texttable Amays_fields whose entries ir
. B nomnal donor 17 Selects the items in the texttable Amays_fields whose entries ir
_| O wellfunctioning transplant 15 Selects the items in the texttable Amays_fields whose entries ir
Edit group query
4 T r Create from field...

Figure 3-9. Groups based on ‘individual’.

3.3.2 Hold the CTRL button and click on the square next

to the group color. The square is highlighted in blue (see ]

Figure 3-10) and the members of the group are selected individual v

in the data panel. _l | well-functioning transplant
| N W normal donor

3.3.3 Use the SHIFT key to select more than one group at B () renal dysfunction wjo reject]

a time. H B @ =cutersjecton

Figure 3-10. Group window.



18

One color




4. Preprocessing

19

4.1 Log transformation

Before we can perform statistical tests we need
transform our data, so we get a normal distribution. This
is a prerequisite for these tests.

4.1.1 Select Layer > Data Preparing > Log Transform to
calculate the log intensities of the layer Target. Store the
results in a new layer called LogTarget (see Figure 4-1).

4.1.2 Press <OK>.
The log2 intensities of the Target layer are calculated

and stored in the LogTarget layer. This new layer is add
to the Layers window.

Figure 4-2. The new layer in the Layers window.

Make sure the LogTarget layer is selected in the Layers
window. If you look at the histogram (top right panel),
the shape is a Gaussian distribution. Note that the data

is not yet centered around zero (see Figure 4-3).

Histogram |Data | Dendrogram | Proﬁlesl
|

B8

.04 0§

. .[I Iz.

=
-15 -10 5 (1] 5 10
Range [7.73,7.73]: 1.67%.
Percentage absent: 0.00 %,

Figure 4-3. The ‘LogTarget’-layer.

4.2 Analyze groups

In the next step we will take a closer look at the two
tissue groups (peripheral blood lymphocyte and kidney
tissue). It is likely to assume that both tissue groups
actually can be seen as two different experiments.

4.2.1 Select Profiles > Statistics Wizard. Leave the
orientation on Row and press <Next> (see Figure 4-4).

5 Log transformation

Source

Select a source layer | Target -

Destination
() Owverwrite the source layer

@ Specify a new destination layer LogTarget

Scope

Select a scope you want to take the legarithm from rootScope

Base

Fill in which base the logarithm uses: 3

Minirmum treshald

used. The logarithm of any negative number will result in an undefined value.

If the argument of a logarithm becomes close to zero it may become infinitely large. This
treshold may avoid that. If you choose a negative number there will be no tresholds

Fill in which number will be used as a minimum treshold: | 10e-g|

Lo J|

] Figure 4-1. Settings for log transformation.
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Statistics Wizard =3
Statistics Wizard (3]
Population
The Statistics Wizard provides an easy and interactive way to obtain statistical ParaTneters .
information about your data. Choose the population of the statistic, Fixes the other parameters needed to calculate the statistic,
Orientation
Layer
@ Calculate a statistic for each Row, i.e. the statistical population consists of
= Columnzs LogTarget -
Groups
= Calculate a statistic for each Column, i.e. the statistical population )
~ consists of Rows Grouping ~ fissue v
Group 1 Group 2 | peripheral blood lymphocyt -
Subset
The population is confined to the following subset: Output
[Complete set - () Test value
@ p-value
Back [ <ged vtz ] [ cone

Figure 4-4. Statistics Wizard: step 1.

422 1In the second step select the Independent t-test
(under ‘Independent test (two groups)’) from the list
and click <Next> (see Figure 4-5).

Statistics Wizard =5

Statistic
Choose which statistical quantity you want to calculate.

Tl summarizing Description

£ Yll Independent test (two group: The p-value assodated with the t-test for
s | independent samples, based on pooled
Sl Independent Welch t-t=sf variance.

Independent error t-test
l Mann-Witney test

Bl General LIMMA
Reference LIMMA model

Yl GSEA Independent t-test
\Il GSEA Mann-Witney t-test The t-test tests whether the mean of the two
samples are equal or not,

In GeneMaths XT independent samples for
each gene or array are taken from one layer,
characterizing the independent samples by
different non-overlapping groups.

Local Pooled Error

Wl 2-5core The t-test assumes normality of the data.
- \H Independent test {multiple gr
-3l Paired tests

4 m | 3

[ < Back ][ Next = J[ Cancel

Figure 4-5. Statistics Wizard: step 2.

4.2.3 In the next window, make sure that LogTarget is
selected and the two different tissue groups. Select p-
value as output and click <Next> (see Figure 4-6).

4.2.4 Do not use a correction for multiple testing in the
fourth step.

4.2.5 Click <Finish>.
4.2.6 Select the newly created profile in the Profiles tab.
Click right on the profile name (see Figure 4-7) and

select Sort From Profile.

4.2.7 Click right on the profile in the Profile panel and
select Show as Numbers (see Figure 4-8).

Figure 4-6. Statistics Wizard, step 3.

| Selection I Dendrogram | Ord[+ [+ | @

[ T-test for independent samples
Delete Profile
Edit Prefile

Sort Frem Profile

s

GSM26827
GSM26828
GSM26829
GEM26830

Store Profile
Query from Profile...
Plot View

®

Figure 4-7. Sort From Profile.

v Shew Error Bars

v Show Grid

¥ Show Highlight Ax
Show as Numbers h

o2 Delete Profile
Edit Profile

Sort From Profile
Query From Profile...
Store Profile

<

Figure 4-8. Show as Numbers.

In the Profile panel, the p-values for the row entries are
shown. These p-values give an indication if the mean of
the two groupings are the same. A lot of rows have a p-
value close to 0 indicating that we have two experiments
in the same dataset: the peripheral blood lymphocytes
(PBL) and kidney tissue (BX).

The PBL and BX datasets will be treated as two
experiments. We will create a subset for all the PBL
arrays and another one for all the BX arrays and name
them ‘PBL” and ‘BX’ respectively.
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4.2.8 Set tissue as the current grouping by clicking the
down arrow next to the array groupings button

fé; - = . Select tissue from the list.

4.2.9 To see the current grouping, select the tissue in the
list of array identifiers (see Figure 2-6).

4.2.10 In the Group window, select tissue from the drop
down menu. CTRL click on the square next to tissue.

Group =
tissue -

| ] (7) peripheral blood lymphacyte
| B @ ‘lidney

1| mn k

Figure 4-9. The Group window.

The specified arrays are selected in the Column panel
and are indicated with a blue rectangle (see Figure 4-10).

4
UL DL L D WL LD @ -
############ w
EEr =
[N TN N T TN TR TR T T O T 1)
=== = = = = R = R = B = =
S £ £ £ £ £ £
EEEEEEEEEEEE 2

=
EErxErErxErErErErzEEE -
TCOUTUUOTUOoOTOOOOO =
o o000 o0O00CoOoo o
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oD oooOOooOOooOoOon
CEEEEEEETEEE @
20T DDLDTLD DD o
e A
cooooooooooo® 308D DD DD
C CCCCCCDoCoCCooCCcESEEEECcECECc S £ C &
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Figure 4-10. Selected arrays.

4.2.11 Select Subset > Selection to Subset and name the
subset BX. Enable Child of the complete set and press
<OK> (see Figure 4-11).

The selected arrays are stored in a subset of the complete
subset (see Figure 4-12). The subset is added to the

Subsets window.

4.2.12 Select the Complete set in the Subsets window.

New Subset ==
Name
BX
Comment
Subset tree
_OI-(
(@) Child of the cument subset
() Child of the complete set

Figure 4-11. Create new subset.

4213 Invert your selection with Selection > Invert
Column Selection. All the PBL arrays are now selected,
indicated with a blue rectangle.

4.2.14 Select Subset > Selection to Subset and name the
subset PBL. Enable Child of the complete set and press
<OK>.

In the Main window, the BX and PBL sets are both
stored as a child of the ‘Complete set’ (see Figure 4-12).
Clear the selection by pressing F4.

% Complete set (Spots x Arrays)

FEL oy 5&'

Figure 4-12. Complete set and the two subsets.

4.3 Filtering

In Figure 1-5, the fourth column represents the P/M/A-
calls (Present/Missing/Absent). These calls are based
on the p-values in the fifth column. These p-values are
calculated from a one-sided Wilcoxon test and give an
indication of the significance of the detection. The
default cut-offs are “P” <= 0.04 < “M” <= 0.06 < “A”.
These values are present in the ‘DETECTION P-
VALUE'- layer.

We are going to clip our data values so that we have a
new layer with only the present calls.

4.3.1 Select the DETECTION P-VALUE layer in the
Layers window and the Complete set in the Subsets
window.

4.3.2 Select Layer > Filtering > Clip Extern.

Fill out the dialog box as shown in Figure 4-13. With
these settings, only the expression values of the
LogTarget layer that have a value smaller than 0.04 (the
P-calls) in the detection p-value layer are selected and
stored in a layer called Clipped.
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[ Clip Layer Extern == Row Query ===
Source Lege | Visual Edit Qe >>

The values of the source will be transferred to the
destination layer if the values or the errors of the quality
layer are within certain boundaries. Otherwise the
destination layer will get an absent value,

Select a source layer lLogTarget ,‘
Select a quality layer [DETECT[ON P-VALUE v|
Destination

) Overwrite the source layer

@ Specify a new destination layer Clipped

Scope

Select a scope you want to clip rootScope -
Tresholds

Minimum value present: 0

Maximurn value present: 0.04

Value or error
Values

L .

) Use the values of the quality layer.
Errors

Use the errors of the quality layer.

[ ok || cance

Figure 4-13. Clip Values dialog box.

4.3.3 Click <OK>.

As a first filter we will select all the row entries that have
less than 100% absent calls. Genes without any
expression value are useless anyway.

4.3.4 Select the Clipped layer and the BX subset in the
Main window.

4.3.5 Select Selection > Row Selection from Query and
click on the Statistics Query tab and then <Statistics
Builder> (see Figure 4-14).

4.3.6 The Statistics Wizard opens. Make sure the
orientation is set to Row and the Complete set is
selected. Click <Next>.

4.3.7In the second dialog, select the Fraction absent
values statistic (under ‘Summarizing’) and click <Next>
(see Figure 4-15).

4.3.8 In the next dialog, make sure you have the layer
Clipped selected and click <Next> once more.

@ Replace current selection
Additional Queries  »»

) Search in current zelection [AMD)]
1 Add to current selection [OR]

[Feld | Value | Emor | Pattem | Limit Fold Change | Statistics Query |

Expression
|

[ statistcs BuilderEy | Expression Buider >> |

o) o ) oy

Figure 4-14. Row selection from query.

Statistics Wizard =3

Statistic
Choose which statistical quantity you want to calculate.

-1l Summarizing » | Description
- Mea!n The fraction of absent values in a population.
il Median

-l Percentile

-'{ll Standard deviation L

-l Root mean square (Rf|

-'{ll Coeffident of Variatiol

-'ill Mean absolute deviati

-{ll Mean Error

W
i Median Error

-l Error Percentile

~Yll Kolmogorov test of na

il Minimum Value

. Mzvirn i Wl iz
4 1 3

l < Badk ” Next > ]l Cancel J

Figure 4-15. Choose which statistical quantity you
want to calculate.

4.3.9 In the last window, set the value to < 1 (= 100%).
GeneMaths XT will select all the row entries that have
less than 100% absent calls, thus having at least one
present call for at least one array. Click <Finish> and
<OK> to close the query wizard.

The selected row entries (indicated with a blue arrow in
the Rows panel) will be used for further analysis. First
we need to store these selected row entries in a new
subset. Make sure the subset BX is selected in the Subsets
window.

4.3.10 Select Subset > Selection to Subset and give the
new subset a name, e.g. At Least 1 P-call in BX. Store the
selection in a new subset as a child of the current
selected BX subset (Figure 4-16) and press <OK>.
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Mew Subset (3]

Name
At Least 1 P-callin BX

Comment

Subset tree
(@ Child of the cumrent subsst

(") Child of the complete set

K

Figure 4-16. Create a new subset.

4.3.11 Clear the selection with F4

4.3.12 Repeat steps 4.3.4 - 4.3.9 for the PBL subset.
Alternatively click CTRL+Q and change ‘BX’ in the
Expression panel to ‘PBL’ (see Figure 4-17). Press <OK>.

Row Query @

Logic Wisually Edit Query =3
@ Replace current selection
Additional Queries >

() Search in cument selection [AND)
() Add to curent selection [OR)

|Field | Value | Emor | Pattem | Limit Fold Change | Statistics Query

Expression
RowAbsentFraction(Clipped' "PBL}<1

’Statistics Builder>> ] [ Expression Builder »> ]

[ ok [ camcel |[ ooy |

Figure 4-17. Row Query for PBL.

4.3.13 The selected files are indicated with a blue
rectangle and will now be stored in a new subset. Select
the 'PBL’ subset in the Subsets panel in the Main window

(HEeeL ).

4.3.14 Select Subset > Selection to Subset and give the
new subset a name, e.g. ‘At least 1 P-call in PBL’. Store
the selection in a new subset as a child of the current
PBL subset and press <OK>.

4.3.15 Clear the selection with F4. The Subsets panel
should now look like this:

ﬁ Complete set (Spots x Arrays)
R atleast 1PcalinBX | o] [,
=5 PaL
¥ i 4 At Least 1 P-cal in PBL &
F
BT
=[] 2y

Figure 4-18. The Subsets window.

4.4 Normalization of arrays

To compare the arrays with each other, the arrays must
be normalized before we can draw statistically valid
conclusions.

4.4.1 Select Layer > Normalization > Arrays. Fill out the
dialog box as shown in Figure 4-19. These settings will
center our data around zero.

ﬁ Mormalize Arrays @
Source
Select a source layer Clipped =
Destination
() Overwrite the source layer
@ Specify a new destination layer Mormalized
Subset
Statistics are based on: Complete set n
Offset

Select which an algorithm calculates the offset:

Scaling

Select which an algorithm calculates the scaling:

Standard deviation A

[ 0K l [ Cancel ]

Figure 4-19. Settings for the normalization of the
arrays.

4.4.2 Click <OK>.

The histogram of the new layer Normalized is now
nicely centered around zero as shown in Figure 4-20.

Histogram |Data | Dendrogram | Proﬁlesl
|

02 04 08 08

..

-4 -2 ] rd

Figure 4-20. Data centered around zero.
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Now we have a starting point for further statistical
analysis. Our aim is to find expression patterns that are
unique for rejection, dysfunction without rejection and
well functioning transplants for PBL and BX.

5.1 Hierarchical clustering

5.1.1 Make sure that no row/column entries are selected
by pressing F4.

5.1.2 Select Patient ID as the column identifier to
address the arrays with these names.

ID(Arrays)
geo_accession(Arrays)
source_name_chl (Arrays)

description(Arrays)

individual{ Arays) «

supplementary_file(Arrays)
tissue(Arrays)

*  individual (Arrays)
Age(Arrays)
Clinical status(Arrays)
Sex(Arrays)
Immunosupression{Arrays)
Histopathology(Arrays)
Donor type(Arrays)
Scr (mg/dL)(Arrays)
Days post transplant{Arrays)

Patient_ID(Arrays) h-

*TX = well functioning transplant

* AR = acute rejection group

*C = normal donor

*NR = renal dysfunction w/o rejection

Click on the down arrow next to the array groupings

button '?Ef “. 7 and select individual. Individual is now

set as the current grouping (see Figure 5-1).

Patient_ID(ATays) 4

Figure 5-1. Colors correspond to the ‘individual’

grouping, the names to the Patient ID

information.

1) BX-subset

5.1.3 Select the At Least 1 P-call in BX subset in the
Subsets window.

ﬁ Complete set (Spots x Arrays)
SN
NN 4t Least 1P-callin BX | [
=¥ PaL
w388 At Least 1P-callin PBL g
F
e|[ae
= L

5.1.4 Select Analysis > Cluster Analysis or press [Aa .
Fill out the dialog box as shown in Figure 5-2. Make sure
the orientation is based on the Columns and press
<Next>.

Dendrogram: data (=]
Based on
) Rows (@ Columns
Layer Subset
Mormalized hd ] [At Least 1 P-cal in BX hd
Data Filter

Optionally filter your data to focus on spedific facet.

This filter takes the value of the layer -
and only the entries belonging to the
subset, It does not change the data in
any way.

Group average
Principal Compaonent Analysis
Time-based polynomial fit

’ Cancel ] [ MNext =

Figure 5-2. Cluster analysis: step 1.

We are going to create a UPGMA dendrogram using
Pearson correlation as a similarity coefficient.

5.1.5 Make sure the Pearson correlation coefficient is
selected and press <Next> (see Figure 5-3).

5.1.6 In the next step select UPGMA and press <Finish>.
5.1.7 GeneMaths XT will tell us that we have missing
values in our layer. Because we are fully aware of this

we will continue with these absent values. Press <Yes>.

5.1.8 The dendrogram pops up in the Main window.
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Dendrogram: similarity =]

Choose here which distance or similarity you want to use to compare two entries,

Pearson correlation A pearson correlation compares -

Squared Pearson correlation global trends in the data: it
Cosine correlation focuses on changes in the signal
Eudidean distance {inear scaled) and disregards the amplitude or
Eudlidean distance {(exponentially scaled) the offset of the signal.
Manhattan distance
Chebychev distance
Eudidean distance {with variances)
Eudidean distance {with variances, exponen
Spearman Ranks
Jaccard
Dice
Simple Matching

[ Cancel ] [ < Back ] [ Next =

Figure 5-3. Settings for the cluster analysis.

5.1.9 You can select branches by pressing CTRL and the
left mouse button while pointing to the branch node.
The arrays belonging to that branch are selected.
Pressing F4 clears the selection.

5.1.10 Select a branch and click on the right mouse
button. A menu pops up. Select Swap branch. The
members of the selected branch are swapped. Please
note that the swapping branches does not alter the
similarities in a dendrogram, it is just a different way of
visualization.

5.1.11 Swapping the branches of the BX subset gives an
indication of the clustering (see Figure 5-4). The
members of the ‘individual’ grouping cluster relatively
good together, except for the ‘renal dysfunction w/o
rejection group’ (= NR). Because this can be a disturbing
factor in further analysis, we will create a new subset
with only the arrays that cluster well together and
exclude the ‘renal dysfunction w/o rejection” group.

Dendrogram MNormalized <

Wﬁﬁﬁﬁ

| Patient_ID(Amays) |

ART
AR
ARZ
ARS
NRS
NR1
ARG
ARS
AR3

I NR2
X8
@10
™
X3
TX4
X5
X6
X2
TX9
X7
c9
c6
NR8
c8
NR3
c3
c4
c1
c2
c7
cs

Figure 5-4. Dendrogram of the BX subset.

5.1.12 In the Group window, select individual from the
list. Select all groups except for the ‘renal dysfunction
w/o rejection” group by CTRL clicking on the square
next to the group.

individual -]

H | [ wel-functioning transplant
| B ] W normal donor

. ®) renal dysfunction wjo rejection
| B ] @ ocute rejection

Figure 5-5. The Group window.

5.1.13 Select Subset > Selection to Subset and store the
selection as No NR. Enable Child of the current subset
and press <OK>.

Next, we are going to make a dendrogram for this new
subset.

5.1.14 Select Analysis > Cluster Analysis or press [Aa .

Make sure the orientation is based on the Columns and
the No NR subset and the Normalized layer are
selected. Press <Next> twice and then <Finish>.

Figure 5-6. Dendrogram of a selection of the
BX subset.

2) PBL-subset

5.1.15 Press F4 to unselect the arrays.

5.1.16 Repeat steps 5.1.3. to 5.1.8 for the At Least 1 P-call
in PBL subset.

5.1.17 Swapping the branches of the PBL subset gives an
indication of the clustering. The “Acute Rejection” group
(= AR) does not cluster well (see Figure 5-7).
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[t

Figure 5-7. Dendrogram of PBL subset.

ART
NRS
NR2
NR3
AR2
AR3
C5

TX3
TX7
X1
X2
TX4
TXB
X8
TXS
TX8
NRE
NR4
NRT
NRB
NR1
c1

ca

CB

c7

c3

c2

c4

AR4
ARS
ARG

|Pat|am_ID(Arrays) - ‘ Dendrogram Mormalized -

5.1.18 In the Group window, select all groups of the
individual grouping, except for the “Acute Rejection’

group.
5.1.19 Select Subset > Selection to Subset and store the

selection as No AR. Enable Child of the current subset
and press <OK>.

5.1.20 Make a dendrogram for this new subset. Select

Analysis > Cluster Analysisor press [ . Make sure

the orientation is based on the Columns and the No AR
subset and the Normalized layer are selected. Press
<Next> twice and then <Finish>.

il

Figure 5-8. Dendrogram of a selection of the BX
subset.

| Patient_|D{Amays) « |Dendmgrzm Mormali...

51.21Swap the branch in such a way that the
dendrogram looks like the one in Figure 5-8. Press F4 to
unselect all arrays and select the TX-branch (CTRL + left
click on the branch node) All arrays belonging to this
branch are selected (see Figure 5-9).

Statistics report

Grouping: individual

Subset: No AR

Total number of items: 25
Selected number of items: 10
Expected ratio: 0.4

5.1.22 Right click on the branch and select Branch to
Statistics Report (see Figure 5-9).

Cluster Analysis...
Bootstrap Analysis...

Euclidean Distance Analysis...

Show Dendrogram

Swap Branch

Branch to Selection
Branch to Subset...
Branch te Group...
Branch to Profile

Branch to Statistics Repo

“FFFFFFFFCZZ2%=

I o
ZZ 0 ¢

Figure 5-9. Opening the statistics report of the
selected branch.

5.1.23 The report gives the odds of having the C5 in the
TX branch (see Figure 5-10).

The array with Patient_ID C5 (normal donor) has 40% (
= 0.4) chance of being present in the TX branch. The
actual ratio of being present in the TX branch is 12.5% (=
0.125), this corresponds to a p-value of about 0.06. This
means that the odds of having C5 in the TX branch is
much less than by chance.

3) Remarks

*Please note that a dendrogram based on the
‘LogTarget’-layer will look exactly the same as the one
based on the ‘Normalized’-layer when using Pearson.
Why?

*What if you use Euclidean distance instead of Pearson,
does this influence the shape of the dendrogram in
both layers?

*If we would use the median/MAD instead of the
mean/stdev as parameters for the normalization of
the arrays, would this influence the results? Why
(not)?

Category Binomial p-Value Hypergeometric p-Value Total Partial Ratio z-Score
well-functioning transplant 6.79535e-006 4.89482e-006 9 9 1 4.5

renal dysfunction w/o rejection 0.00606997 0.00594966 8 0 0 -2.74398
normal donor 0.0592297 0.0654462 8 1 0.125 -1.88648

Figure 5-10. Statistics report.
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5.2 Differentially expressed genes

In this part we will try to find the differentially
expressed row entries for each clustered group.

1) Kidney tissue (BX)

For the kidney tissue (BX) subset we will compare:

*Well functioning transplant (TX) versus an acute
rejection (AR)

*Well functioning transplant (TX) versus a normal
donor (C)

TX vs. AR

First we are going to select all differentially expressed
genes with a T-test. We will use a 0.001 significance level
and correct for multiple testing. Make sure that no row
or column entries are selected by pressing F4.

5.2.1 Select Selection > Row Selection from Query (or
press CTRL+Q) to open the Row Query dialog box. Click
on the Statistics Query tab and then press on <Statistics
Builder>.

5.2.2 Select the No NR subset and click <Next>.
5.2.3 In the next window, select the Independent t-test

(under ‘Independent test (two groups)’) and click
<Next> (see Figure 5-11).

Statistics Wizard @

Statistic
Choose which statistical quantity you want to calculate.

-1l Summarizing Desaiption
= \l Independent test {two aroup: The p-value associated with the t-test for
Independent t-test independent samples, based on pooled

Bl Independent Welch t-tesi variance,
Sl Independent error t-test
B Mann-witney test
General LIMMA

Sl Reference LIMMA model

GSEA Independent t-test

[l GSEA Mann-witney t-test The t-test tests whether the mean of the two
zamples are equal or not.

B Local Pooled Error

z-Score The t-test assumes normality of the data.
+- \,H Independent test {multiple g

+- Yl Paired tests

In GeneMaths XT independent samples for
each gene or array are taken from one layer,
characterizing the independent samples by
different non-overlapping groups.

4 T »

l < Back ” Next = ]l Cancel

Figure 5-11. Choose statistical quantity.

5.2.4 Fill out the settings in the next window as shown in
Figure 5-12.

Statistics Wizard @

Parameters
Fixes the other parameters needed to calculate the statistic,

Layer
Mormalized -
Groups
Grouping | individual -
Group 1 _au.lbe rejection - Group 2 |well-functioning transplant =
Qutput
~) Test value
@) p-value

{ < Back H Next = ]l Cancel J

Figure 5-12. Parameters to calculate the statistic.

525 1In the next step, choose Benjamini & Hochberg
procedure to control the false discovery rate (FDR). Press
<Next>.

5.2.6 In the final step, set the threshold to < 0.001 (see
Figure 5-13). Click <Finish> and then press <OK>.

Statics Wizard ==

Compare to value

By comparing the test statistic to a value, a criterion is obtained to select
entries.

Benjamini-Hochberg false discovery rate adjusted
p-values of T-test for independent samples of the
subset No MR of Normalized for groups "acute
rejection” and "well-functioning transplant” (p-value)

< w0001

I < Back ” Finish ]l Cancel I

Figure 5-13. Setting a criterion for the test statistic.

In a next step we are going to store the selected row
entries.
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5.2.7 Select Selection > Store Selection and store the
Row selection as a new query called T-test. Press <OK>.

Store Query (=3

Destination

Store the query of the selection in a query variable. You can store in an
existing query or create a new one.

() Owerwrite an existing query

@ Specify a new destination query T-test

Subset

The query contained in the selection will can be confined to a subset. You
can store the row or column selection.

Select asubset |y MR -

@ Row () Column

[ ok | cancel

Figure 5-14. Store the row query.

The genes are now selected, now we want to select the
TX (Well functioning transplant) and AR (acute
rejection) arrays.

5.2.8 In the Group window, make sure the individual
grouping is selected from the pull down list. Select the
TX (Well functioning transplant) and AR (acute
rejection) groups by CTRL clicking on the square next to
their name (see Figure 5-15).

' individual -]

[ ] || O well-functioning transplant
n normal donor
. renal dysfunction w/o rejection
| B acute rejection

L JO] |

4| i k

Figure 5-15. The Group window.

In the Main window, the TX and AR arrays are now
selected in addition to the previous selected row entries.
We are now going to create a new subset called AR vs.
TX for our selection.

5.2.9 Select the No NR subset in the Subset panel.

5.2.10 Select Subset > Selection to Subset and give the
new subset the name AR vs. TX. Store the selection in a
new subset as a child of the current No NR subset and
press <OK>.

Next, we are going to select all the row entries that have
less than 1% absent calls, thus having at least 99%
present calls.

5.2.11 Select the AR vs. TX subset in the Subsets window.

5.2.12 Select Selection > Row Selection from Query and
click on the Statistics Query tab and then <Statistics
Builder>.

5.2.13 The Statistics Wizard opens. Leave the first dialog
unaltered and click <Next>.

5.2.14 Select the Fraction absent values-statistic (under
‘Summarizing’) and click <Next>.

Statistics Wizard ==

Statistic
Choose which statistical quantity you want to calculate.

-l Summarizing . | Description
1 Mean The fraction of absent values in a population.
-Vl Median

-1l Percentile

/M Standard deviation
-l Rootmean square (RN
-l Coefficient of Variatiol
-1l Mean absolute deviati
-1l Mean Error L
8-
-1l Median Error

/M Error Percentie
-1l Kolmogorov test of no

-l Minimum Value
L Mair i Uaha
4| (1] »

[ < Back ][ Mext = ][ Cancel

Figure 5-16. Statistics wizard: step 2.

5.2.15 In the next dialog, make sure you have the layer
Normalized selected and press <Next>.

5.2.16 In the last window, set the value to < 0.01. Click
<Finish> and <OK> to close the query.

Next, we are going to create a new subset for the
selected genes.

5.2.17 Select the AR vs. TX subset in the Subset panel.

5.2.18 Select Subset > Selection to Subset and give the
new subset the name Present. Store the selection in a
new subset as a child of the current AR vs. TX subset
and press <OK>.

ﬁ Complete set (Spots x Arrays)
R Atleast1PalingX | oD
! =5 No R
; =58 AR vs. TX -
- Present

=3 peL &

=-3F At Least 1P-callin PBL
% Mo AR _'i "lE

Figure 5-17. The Subsets window.
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5.2.19 Normalize

the row entries with Layer >

Normalization > Genes and store the result in a new

layer ‘NormGenes TX_AR’ (see Figure 5-18).

Normalize Genes

Source

Select a source layer | pormalized -

Destination
() Overwrite the source layer

@ Specify a new destination layer MormGenes TX_AR

Subset

Statistics are based on: [ present ']

Offset

Select which an algorithm calculates the offset: [Average

Scaling

Select which an algerithm calculates the scaling:

Standard deviation -

[ o

| [ concel

Figure 5-18. Normalize the genes.

Next, we are going to create a dendrogram for both the

column and row entries.

horizontal zoom slider

Selection | Dendrogi + [ * @

L 2

Selection Rows: 10 selected

Manual selection of =
10 entries(57,11335)

Selection Columns: 7

Manual selection of 7
entries(40 46)

vertical zoom slider

Fatient_|D{Arays) | Dendrogram ...

5.2.20 Press the E button. Make sure the Present

subset and the NormGenes TX_AR are selected. Press
next twice and press <Finish>.

5.2.21 Press the m button. Make sure the Present

subset and the NormGenes TX_AR are selected. Press
next twice and press <Finish>.

5.2.22 To obtain the optimal view of your dendrograms,

—t E = -
use the zoom buttons (& & N SX ) or the

zoom slider (see Figure 5-19).
5.2.23 Unselect the current selection by pressing F4.

5.2.24 Select the AR branch and the upregulated genes
(red color) for this branch (see Figure 5-19): 10 genes are
upregulated in AR (red color) and 128 genes (green
color) are downregulated in AR.

Branches can be abridged to see the average values of
the branch.

5.2.25 Select the branch with the 128 gene members by
clicking on the node. Right click and select Abridge
Branch (see Figure 5-20).

5.2.26 Select the branch with the 10 overexpressed genes

for AR by clicking on the node. Select Selection > Row
Selection to Statistics Report.

Histogram | Datz

§..02.04,08.08 1

L

-2 -1
Range [0.73,0.7:
Percentage abser

Figure 5-19. Two fold clustering.
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Selection | Dendrogram [+ [ @)| :l
Selection Rows: 10 selected

Manual selection of 10 -
entries(57,11335)

+*

Selection Columns: 7 selected

Manual selection of 7 -
entries{40 46)

Dendrogram MormGenes TX_... « I

Expression Values

Histogram | Data | Dendrogram I Pmﬂis|

A

§..02.04 0808,

2 -
Range [0.73,0.73]: 1.36%.
Percentage absent: 0.00 %.

128 members

COTTRO03ET 3 st

s -
mugyuung
1| m | » |

L1 k

D_REF(Spots) &

Figure 5-20. Abridge branches to obtain a better view.

This report (see Figure 5-21) shows which GO ID is
present more or less than expected based on an odd
ratio.

Click on one of the hyperlinks. The GO website opens,
showing the ontology of this term. Based on such report
it is possible to see which GO terms are over/under
expressed in the selected branch.

TX vs. C

*Try now to find the up/down regulated genes for TX
vs. C.
* Are the same genes up/down regulated?

[] Statistics Information

Statistics report

Grouping :GCO ID
Subsst: Present

Total number of items: 138
Selected number of items: 10
Expected ratio: 0.0724638

Binomial p-Value
.0724838
.0724838

Category
GO00513010.000346619 8]
GO00055780.000346619 4]
Go003052680.0192456 0.140167
Go00082640.0192456 0.1401867
Go00064640.0192456 0.14018&7
GO00063660.0192456 0.140167
c000072420.0791388 0.20339
GO00065280.166102 0.262388

LT I S S

Hyvpergeometric p-Value

m_ |

Total Partial

.333333
25 -

I N I S S e
0D oooaoR R
[T

4 I

[ copytocipboard | [ ok

Figure 5-21. Statistics report.
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2) Peripheral blood lymphocyte (PBL)

*Repeat the analysis above but now for the PBL
dataset.

*Find up/down regulated genes for NR vs. TX and TX
vs. C.

* Are the same genes up/down regulated?

*Is there a relation between the genes found in TX vs. C
for the BX dataset and the ones found in the TX vs. C
subset for PBL?

5.3 Comparing statistical tests

Differentially expressed genes can be screened for by
several statistical tests. In the previous steps (5.2.1 -
5.2.6) we detected differentially expressed genes in the
NoNR subset between TX and AR with an independent
T-test (threshold of <0.001 and a correction for multiple
testing). These differentially expressed genes were
stored as T-test (see 5.2.7).

Next we are going to perform two additional tests on
this subset and look if the three tests denote more or less
the same genes as “differentially expressed’.

5.3.1 Select the No NR subset in the Subsets window.

5.3.2 Select Selection > Row Selection from Query (or
press CTRL+Q) to open the Row Query dialog box. Click
on the Statistics Query tab and then <Statistics Builder>.

5.3.3 Select the No NR subset and click <Next>.

5.3.4 In the next window, select the Local Pooled Error
(under ‘Independent test (two groups)’) and click
<Next>.

5.3.5 Fill out the settings in the next window as shown in
Figure 5-12.

5.3.6 In the next step, choose Benjamini & Hochberg
procedure to control the false discovery rate (FDR) and
click <Next>.

5.3.7 In the final step, set the threshold to < 0.001. Click
<Finish> and then press <OK>.

5.3.8 Store the selected row entries with Selection >
Store Selection and name the selection LPE. Make sure
the orientation is set to Row and the No NR subset is
selected. Press <OK>.

5.3.9 Repeat step 5.3.2 - 53.7 but now choose the
Reference LIMMA model (under ‘Independent test
(two groups)’) as test statistic.

5.3.10 Store the selected genes with Selection > Store
Selection and name the selection LIMMA test.

Next we are going to look if the three tests (LIMMA test,
LPE and T-test) denote more or less the same row entries

as “differentially expressed’.

5.3.11 Select Selection > Venn Diagram. Select the three
stored queries and press <OK>.

The Venn diagram pops up in a new window.

LIMMA test Figure 5-22, Venn

Diagram.
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