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1. Import
1.1 Introduction

Mice that lack the aquaporin-1 gene (AQP-1) are
unableto generate a hypertonic medullary interstitium
in their kidneys. Mc. Reynolds et al.(1) investigated the
gene expression profiles of wild-type mice and AQP-
1null mice. 

In a first step total RNA was isolated from the medullas
of 3 wild type mice and 3 aquaporin-1 null mice. Total
RNA from each sample was amplified before labelling
in the cDNA reaction. The hybridization scheme was
based on a loop design: each sample from an individual
mouse was hybridized to an array four times,
generating four independent replicate measures of that
RNA sample. 

This example dataset will be used in order to explain the
workflow of GeneMaths XT. This dataset is publicly
available on the GEO website. 

1.2 Downloading the data

1.2.1 Go to the GEO homepage: http://
www.ncbi.nlm.nih.gov/geo (‘Gene Expression
Omnibus’). Click in the box next to ‘Query > GEO
accession’ and type GSE2402.

1.2.2 Press <Go>.

1.2.3 Scroll down the next page and select SOFT
formatted family file(s).

1.2.4 On the next page select GSE2402_family.soft.gz.

1.2.5 Select <Save> and navigate to the path on your
computer.

1.2.6 Press <Save> to save the file in the selected folder.

(1) McReynolds et al., Renal medullary gene expression
in aquaporin-1 null mice, Am J Physiol Renal Physiol,
288:315-321, 2005.

1.3 Importing the data in GeneMaths XT

1.3.1 Start GeneMaths XT by double clicking on the icon

 on the desktop or from the task bar with Start >

Programs > Applied Maths > GeneMaths XT.

1.3.2 Click <Next> in the welcome screen to begin the
import of the data. If the welcome screen does not
appear, choose File > Import Wizard in the GeneMaths
XT Main window. The Import Wizard window pops up
(see Figure 1-2).

1.3.3 Select the fourth option Import from other sources
and hit <Next>.

1.3.4 Select GEO’s SOFT family in the format list. A
short description of the format is shown in the right
panel (see Figure 1-3).

1.3.5 Click <Next>.

1.3.6 Browse for the file in the File panel. Leave the top
two panels empty (see Figure 1-4). 

Figure 1-1. Download information.

Figure 1-2. Import wizard: select data source. 
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1.3.7 Click <Next>. 

1.3.8 Specify the name of the processed file e.g.
GSE2402.xps.

1.3.9 The Calculation dialog box pops up. The status of
the import of the data is shown (see bottom of the box). 

1.3.10 After the processing of the data (this may take a
couple of minutes) GeneMaths XT will prompt to
specify the contents of the columns in the Define Format
dialog box (see Figure 1-5).

1.3.11 Select the second column ID_REF by clicking on
it. The column is highlighted in pink. Specify the kind of
data in this column by changing the settings in the
Column information panel. Select Text in the Type box and
SpotID in the Text box (see Figure 1-6).

1.3.12 Select the third column CH1_MEAN.
Quantitation, Target, Foreground and Value are
automatically selected as the settings for the third
column (see Figure 1-7).

GeneMaths XT automatically assigns the correct settings to
columns 3-14 as specified in the file. Only for column 2 and
15 the settings need to be changed.

1.3.13 Select the last column and fill out the correct
settings (last row in the list on the next page). 

1.3.14 The Import mapping dialog box pops up asking
you to create a mapping for your data. This mapping
tells GeneMaths XT which quantitations to use in the
session.

1.3.15 Select ID-REF and hit “>”. ID-REF is now placed
in the right box (see Figure 1-8).

Figure 1-3. Import wizard: select format. 

Figure 1-4. Import Wizard: Input file. 

Figure 1-5. The Define Format dialog box. 
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Figure 1-6. Settings for the second column. 

Figure 1-7. Settings for the third column.

Column   Type   Quantitation    
4 (CH1_SD)  Quantitation Target  Foreground Error 
5   (CH1_BKG_MEAN) Quantitation Target  Background Value 
6   (CH1_BKG_SD)  Quantitation Target  Background Error 
7   (CH1_MEDIAN)  Quantitation Target  Foreground Value 
8   (CH1_BKG_MEDIAN) Quantitation Target  Background Value 
9   (CH2_MEAN)  Quantitation Reference     Foreground Value 
10 (CH2_SD)  Quantitation Reference     Foreground Error 
11 (CH2_BKG_MEAN) Quantitation Reference     Background Value  
12 (CH2_BKG_SD)  Quantitation Reference     Background Error  
13 (CH2_MEDIAN)  Quantitation Reference      Foreground Value  
14 (CH2_BKG_MEDIAN)  Quantitation Reference      Background Value  
15 (VALUE)  Quantitation Ratio           Foreground Value  
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1.3.16 Click <Next>.

1.3.17 Mark the two checkboxes in the Filter panel of the
next dialog box. Marking these boxes means we want to
load both channels in a different layer and that we want
to have the background for each channel in a different
layer as well (see Figure 1-9).

1.3.18 In the Quantitations panel, use the MEDIAN
quantitations as depicted in Figure 1-9 and the standard
deviations (‘SD’) as their error values. Use the pull down
menu to select the predefined signals.

1.3.19 In the next step of the import, you can define an
extra quantitation. In this exercise, we do not need an
extra layer.

1.3.20 Click <Next>.

GeneMaths XT will import the data in a new session.
The Main window of GeneMaths XT appears as depicted
in Figure 1-12. The session contains 4 layers (displayed
in the top left panel), 9 row identifiers and 4 column
identifiers (Figure 1-10 and Figure 1-11).

NOTE: Do not forget to save your session on a regular basis

by pressing . 

          

Figure 1-8. The Import Mapping dialog box: step 1. 

Figure 1-9. Import Mapping, step 2. 

Figure 1-10. 6 column identifiers.

Figure 1-11. 9 row identifiers.
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Figure 1-12. The Main window of GeneMaths XT after import of the data. 
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2. Annotation
The annotation is automatically done via the import of
the file. A file called ‘loopannot.txt’ contains additional
array information for this dataset and can be found on
our website. 

2.0.1 Select ‘Download’ in the menu bar of our home
page (www.applied-maths.com) and select ‘Manuals &
Tutorials’. Scroll down the page and select ‘GeneMaths
XT Tutorials’. In the new window, click with your right
mouse button on ‘Array Annotations’ next to ‘Loop
Design’ and select ‘Save Target As…’. Save the file as a
text file in a folder on your computer.

2.0.2 Select Textfields > Import.

2.0.3 Select the Arrays aspect and navigate to the
annotation file in the File panel. 

2.0.4 Use the ID field in the session and the ID column
in the file to link the data (see Figure 2-1). Select

Ch1Type and Ch2Type while holding the SHIFT
button. Press <OK>.

2.0.5 Click on the column identifier tab in the Main view.
The new information fields are added to the list of
identifiers (red rectangle). 

Figure 2-1. Adding new information fields to the list of column identifiers. 

Figure 2-2. New column identifiers. 
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3. Groupings
With the statistics we want to perform later on in mind,
we need to define groupings, each containing a set of
particular groups. The groupings will then later be the
input for the statistical tools and visualizations. 

3.0.1 Select Groups > Edit Column Groups and click on
<Create New Grouping>. 

3.0.2 In the next window, select Ch1Type from the Name
pull down menu and click <OK> (see Figure 3-1).

3.0.3 Ch1Type is selected as the text field in the next
window (see Figure 3-2). Uncheck ALL the limitations
and click <OK>.

3.0.4 The groups based on the settings are shown in the
next window (see Figure 3-3).

3.0.5 Repeat the previous steps for Ch2Type (see Figure
3-4).

3.0.6 Press <Exit>.

Figure 3-1. Grouping from Ch1Type. 

Figure 3-2. Creating groups based on Ch1Type. 

Figure 3-3. Groups based on Ch1Type. 
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Figure 3-4. Groups based on Ch2Type. 
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4. Visualizing the loop design
GeneMaths XT offers a nice visualization tool to shows
the design of your arrays.

4.0.1 Select View > Draw Design. 

4.0.2 Select the array fields containing the sample names
for the Cy5 channel (red, target) and the Cy3 channel
(green, reference); Sample_source_name_ch1 and
Sample_source_name_ch2 respectively. Select the two
groupings corresponding to each channel and press
<OK> (see Figure 4-1).

In the next window, the set-up of the microarray is
displayed: each sample (3 WT mice and 3 KO mice) is
measured four times (two times labeled with a red dye
and two times labeled with a green dye).

Figure 4-2. Graphical representation of the loop design. 

Figure 4-1. Settings for displaying the experimental
design. 
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5. Preprocessing
Prior to the analysis of the data, thorough preprocessing
steps need to be performed. In these preprocessing
steps, sources of variation from the measured
expression values are removed. 

5.1 Sources of variation

First we are going to look at the data and its major
sources of variation by creating an ANOVA report.
ANOVA models the measured expression level of each
gene as a linear combination of the major sources of
variation. 

5.1.1 Select Layer > Normalization > Anova Report. Fill
out the settings as depicted in Figure 5-1.

5.1.2 Press <OK>. The ANOVA report is displayed (see
Figure 5-2).

The SS-value describes for each effect its contribution to
the global variation in the experiment. From the
obtained ANOVA table we can see that all effects
contribute to the variation. In the preprocessing steps
we are going to remove most sources of variation. 

5.2 Background correction

First we are going to correct the target and reference
layer for non specific background noise. 

5.2.1 Select Layer > Data Preparing > Background
Correction. Select the target layers and use the subtract
algorithm (see Figure 5-3). Store the corrected values in
layer Tar_BG_corr.

5.2.2 Press <OK>. 

Figure 5-2. ANOVA report. 

µ  =  The overall average signal  
A  =  Array effect 
D  =  Dye effect 
AD =  Array-dye effect 
G  =  Gene effect 
VG =  Variety-gene effect 
AG =  Array-gene effect or spot effect 
DG =  Dye-gene effect 
SS  = Sums of Squares 
df  = Degrees of freedom 
MS = Mean Squares (= SS/df) 

Figure 5-1. Settings for ANOVA. 
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5.2.3 Apply background correction to the reference
layer. Select Layer > Data Preparing > Background
Correction and use the settings as depicted in Figure 5-4
and store the corrected values in a new layer called
Ref_BG_corr.

5.3 Variance stabilization

The variance stabilization method (vsn) is a method to
preprocess DNA microarray intensity data. This
transformation is equivalent to the natural logarithm in
the high-intensity range and to a linear transformation
in the low-intensity range. In an intermediate range, the
‘arsinh’ function interpolates smoothly between the two.
An advantage of vsn-transformation over log-
transformation is that vsn works also on values that are
negative after background substraction.

5.3.1 Call the variance stabilization R-routine
(Bioconductor) with Layer > Data Preparing > Variance
Stabilization.

5.3.2 Fill in the settings as shown in  Figure 5-5 and press
<OK>. 

5.3.3 Repeat the previous step for the Ref_BG_corr
layer.

5.3.4 Select Layer > Normalization > Anova Report. Fill
out the settings as depicted in Figure 5-6.

5.3.5 Press <OK>. The ANOVA report is displayed.

Figure 5-3. Background correction for the target
layers. 

Figure 5-4. Background correction for the reference
layers. 

Figure 5-5. Variance stabilization. 

Figure 5-6. Settings for ANOVA. 
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From the obtained ANOVA table (Figure 5-7) we can see
that the contribution of all of the effects has dropped
compared to our first ANOVA report (Figure 5-2). The
Gene effect has the highest impact. The Spot effect (=
spots of a gene may contain a different amount of cDNA
on the different arrays) has the second highest impact
followed by the Array effect.

5.4 Normalization 

A. Analyzing the data

5.4.1 Select Profiles > Plot Wizard. Select Columns as
orientation and because we want different layers to plot
against each other, select One column, different layers
and click <Next>.

5.4.2 In the next window select Entries. Select all entries
and click <Next> to move to the next step. 

NOTE: To select all entries select the first entry scroll down
the list and select the last entry while holding the CTRL
button. 

5.4.3 In the third window, select the two transformed
layers Tar_BG_corr and Ref_BG_corr. Click “>” and
click <Next>.

Figure 5-7. ANOVA report. 

Figure 5-8. Plot Wizard: step 1. 

Figure 5-9. Plot Wizard: step 2. 
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5.4.4 In the final window, select MA-plot in the Plot type
panel and Curve color in the Color panel. Click
<Finish>. (M=log2(Red Intensity/Green Intensity) and
A= v(Red Intensity x Green Intensity)).

The plot appears in GeneMaths XT. We need to set the X
and Y axes correctly for the plot.

5.4.5 Select the Ref_BG_corr layer in the Profiles panel.
Click right and choose Set as y-axis (see Figure 5-12).

5.4.6 Select the Tar_BG_corr layer and choose Set as x-
axis. 

5.4.7 Select Profiles > Selected Profile > XY to RI.

5.4.8 Select Profiles > Selected Profile > Lowess Plot.
Press <OK> in the next window. The plot should now
look like the one in Figure 5-13.

Figure 5-10. Plot Wizard: step 3. Figure 5-11. Plot Wizard: final step. 

Figure 5-12. MA-plot. 
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The MA-plot (see Figure 5-13) shows that at a certain
average level of intensities, the ratio M approximates a
certain constant level. However, some deviation in the
plot is caused by a difference in sensitivity between the
two channels. A solution for this problem is to use an
‘Intensity dependent normalization’. We will use the
Lowess normalization to compensate for these intensity
dependent effects. 

B. Lowess normalization

5.4.9 Select Layer > Normalization > Lowess. Select the
layers with the transformed intensities (Figure 5-14). 

5.4.10 Click <OK> and keep the default settings in the
next dialog.

5.4.11 Click <OK>.

5.4.12 Select the first profile in the Profiles panel. Click
right and choose Edit Profile. Press <OK>.

5.4.13 Repeat the previous step for the other profile in
the Profile panel. The plot should now look like Figure 5-
16. There is a compensation for the intensity dependent
effect. Lowess thus allows for both normalization and
linearization of the data.

Figure 5-13. MA-plot with the correct axes. 

Figure 5-15. Edit Profile. 

Figure 5-14. Lowess Normalization settings. 
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5.4.14 Go back to the Main window by clicking on the
Complete set tab (see screenshot below).

5.4.15 Select Layer > Normalization > Anova report. Fill
out the settings as depicted in Figure 5-17. 

5.4.16 Press <OK>. The ANOVA report is displayed
(Figure 5-18).

From the obtained ANOVA table (Figure 5-18) we can
see that the effects of Dye and Array-dye have dropped
substantially compared to Figure 5-7. By normalizing
the genes we have compensated for the dye effect and
subsequently also for the cross effect of array and dye.

C. Array normalization

In the next step we are going to normalize our two
layers. 

5.4.17 Select Layer > Normalization > Arrays. 

5.4.18 Select the Tar_BG_corr layer and store the
normalized array in a new layer called Normalized_Tar.
Do not change the rest of the settings and press <OK>
(see Figure 5-19). 

5.4.19 Repeat the previous step for the Ref_BG_corr
layer and store the layer as Normalized_Ref. 

The histograms of the new layers Normalized_Tar and
Normalized_Ref are now centered around zero.

Figure 5-16. The MA-plot after Lowess
normalization. 

Figure 5-18. ANOVA report. 

Figure 5-17. Settings for ANOVA. 
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5.4.20 Select Layer > Normalization > Anova report. Fill
out the settings as depicted in Figure 5-20.

5.4.21 Press <OK>. The ANOVA report is displayed
(Figure 5-21).

From the obtained ANOVA table (Figure 5-21) we can
see that the Array, the Dye and Array-dye effects have
dropped significantly compared to the previous
ANOVA report (Figure 5-18). With these dye and array
effects reduced to the minimum, we can start a
comparison knowing that the major source of variation
will be the expression level of the different genes.

Figure 5-19. Settings for the normalization of the
arrays. 

Figure 5-20. Settings for ANOVA. 

Figure 5-21. ANOVA report. 
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6. Statistics & Analysis
Now we have a starting point for our statistical analysis.
We are going to perform a LIMMA-test to find
differentially expressed genes between the wild type
and the knockout mice.

6.0.1 Select Profiles > Statistics Wizard. Leave the
orientation on Rows and press <Next> (see Figure 6-1).

6.0.2 Select General LIMMA from the submenu
‘Independent test (two groups)’. 

LIMMA will tests whether the mean of the two
groupings ‘Wild type’ and ‘Knockout’ in the two-color
design are equal or not. 

6.0.3 Click <Next> (see Figure 6-2).  

6.0.4 In the next window, make sure that
Normalized_Ref is selected and the two different
groups in the Ch2Type-grouping. Select p-value as
output and click <Next> (see Figure 6-3).

6.0.5 In the next window, select Normalized_Tar in the
Layer panel, source_name_ch2 (cy3) and
source_name_ch1 (cy5) in the Samples panel and
Ch1Type as grouping for the transformed target layer
(Figure 6-4).

6.0.6 Do not use a correction for multiple testing in the
fourth step.

Figure 6-1. Statistics Wizard, step 1. 

Figure 6-2. Statistics Wizard, step 2: selecting the
test. 

Figure 6-3. Statistics Wizard, step 3. 
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6.0.7 Click <Finish>.

6.0.8 Select the newly created profile in the Profiles tab.
Click right on the profile name (see Figure 6-5) and
select Sort From Profile. 

6.0.9 Click right on the Profile panel and select Show as
Numbers (see Figure 6-6).

In the Profile panel, the p-values for the genes are shown.
These p-values give an indication if the mean of the two
groupings (Wild type and Knockout) are the same. Row
entries having a p-value close to 0 indicates that these
genes are differentially expressed between the Wild type
and Knockout mice. In a next step we are going to select
those genes with a p-value smaller than 0.001.

6.0.10 Click right on the profile name in the Profiles tab
(see Figure 6-5) and select Query from Profile.

6.0.11 Set the threshold to < 0.001 and press <OK>.

6.0.12 Select the Selection tab in the Profile panel. A short
description is given of the selected rows. 85 rows (=
genes) with a p-value smaller than 0.001 are selected
(blue arrow in the Main Window).

Next we are going to store the selection in a new subset
and look at the descriptions of the differentially
expressed genes.

Figure 6-4. Statistics Wizard, step 4. 

Figure 6-5. Sort From Profile. 

Figure 6-6. Show as Numbers. 

Figure 6-7. Setting a criterion for the test statistic. 
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6.0.13 Select Subset > Selection to Subset and give the
new subset the name Differentially expressed. Press
<OK>.

Next we are going to look which genes of the
Differentially expressed subset are downregulated and
which ones are upregulated.

6.0.14 Click on the down arrow next to the array

groupings button  and select Ch1Type.
Ch1Type is now set as the current grouping.

6.0.15 Select Profiles > Plot Wizard. Select Columns for
the orientation, Differentially expressed as subset and
Different Columns, one layer in the Data panel. Click
<Next>.

6.0.16 In the next window select Group average of
grouping Ch1Type and press <Next> to move to the
next step. 

6.0.17 In the third window, select the Normalized_Tar
layer and click <Next>.

6.0.18 In the final window, select MA-plot in the Plot
type panel and Entry color in the Color panel. Click
<Finish>. (M=log2(Red Intensity/Green Intensity) and
A= v(Red Intensity x Green Intensity)).

Figure 6-8. Create a new subset. 

Figure 6-9. Plot Wizard: step 1. 

Figure 6-10. Plot Wizard: step 2. 
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6.0.19 Make sure that no entries are selected by pressing
F4.

6.0.20 Select all entries below the zero of the Y-axis by
pressing the SHIFT button and dragging the left mouse
button over the screen.

6.0.21 Select Groups > From Row Selection and click
<Add new>.

6.0.22 In the new window, enter a name for the group,
e.g. Downregulated and press <OK>.

6.0.23 Press <Yes> to confirm the assignment of the new
group and press <Exit>.

6.0.24 Make sure that no entries are selected by pressing
F4.

6.0.25 Select all entries above the zero of the Y-axis.

6.0.26 Select Groups > Edit Row Groups and click <Add
new>.

6.0.27 In the new window, enter a name for the group,
e.g. Upregulated and press <OK>. Press <Yes> and
press <Exit> to close the window.

6.0.28 Make sure that no entries are selected by pressing
F4. The plot should now look like the one in the next
screenshot:

6.0.29 Select several entries in the plot by holding the
CTRL button and clicking with your left mouse button
on the entries. 

6.0.30 Click on the ‘Differentially expressed:
Normalized_Tar’ tab to go back to the Main window.

6.0.31 The selected entries are marked with a blue arrow
in the Row entries panel. The color codes (upregulated
versus downregulated) are also displayed.

6.0.32 In order to find the up- and downregulated genes
in the Normalized_Ref layer, repeat steps 6.0.14-6.0.30
with the Ch2Type set as grouping and the
Normalized_Ref as layer.

Figure 6-11. Plot Wizard: final step. 

Figure 6-12. Enter a name for the new group. 

Figure 6-13. Selected entries. 


	1. Import
	1.1 Introduction
	1.2 Downloading the data
	1.3 Importing the data in GeneMaths XT

	2. Annotation
	3. Groupings
	4. Visualizing the loop design
	5. Preprocessing
	5.1 Sources of variation
	5.2 Background correction
	5.3 Variance stabilization
	5.4 Normalization

	6. Statistics & Analysis

